Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

CVE ID:CVE-2020-8927
Description:A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
Test IDs: 1.3.6.1.4.1.25623.1.0.853470   1.3.6.1.4.1.25623.1.0.878456   1.3.6.1.4.1.25623.1.0.878504   1.3.6.1.4.1.25623.1.0.878455   1.3.6.1.4.1.25623.1.1.2.2020.2163   1.3.6.1.4.1.25623.1.0.878421   1.3.6.1.4.1.25623.1.0.878470   1.3.6.1.4.1.25623.1.0.844637   1.3.6.1.4.1.25623.1.0.878473   1.3.6.1.4.1.25623.1.1.2.2020.2173   1.3.6.1.4.1.25623.1.1.2.2020.2508   1.3.6.1.4.1.25623.1.0.704801   1.3.6.1.4.1.25623.1.0.892476   1.3.6.1.4.1.25623.1.1.2.2021.1665   1.3.6.1.4.1.25623.1.1.2.2021.1574  
Cross References: Common Vulnerability Exposure (CVE) ID: CVE-2020-8927
https://github.com/google/brotli/releases/tag/v1.0.9
Debian Security Information: DSA-4801 (Google Search)
https://www.debian.org/security/2020/dsa-4801
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MMBKACMLSRX7JJSKBTR35UOEP2WFR6QP/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/W23CUADGMVMQQNFKHPHXVP7RPZJZNN6I/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/M4VCDOJGL6BK3HB4XRD2WETBPYX2ITF6/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WW62OZEY2GHJL4JCOLJRBSRETXDHMWRK/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/356JOYTWW4BWSZ42SEFLV7NYHL3S3AEH/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/J4E265WKWKYMK2RYYSIXBEGZTDY5IQE6/
https://lists.debian.org/debian-lts-announce/2020/12/msg00003.html
SuSE Security Announcement: openSUSE-SU-2020:1578 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00108.html
https://usn.ubuntu.com/4568-1/




© 1998-2021 E-Soft Inc. All rights reserved.