Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

CVE ID:CVE-2012-2370
Description:Multiple integer overflows in the read_bitmap_file_data function in io-xbm.c in gdk-pixbuf before 2.26.1 allow remote attackers to cause a denial of service (application crash) via a negative (1) height or (2) width in an XBM file, which triggers a heap-based buffer overflow.
Test IDs: 1.3.6.1.4.1.25623.1.0.881573   1.3.6.1.4.1.25623.1.0.870883   1.3.6.1.4.1.25623.1.0.123755   1.3.6.1.4.1.25623.1.0.864647   1.3.6.1.4.1.25623.1.1.4.2012.0841.1   1.3.6.1.4.1.25623.1.1.4.2012.0844.1  
Cross References: Common Vulnerability Exposure (CVE) ID: CVE-2012-2370
BugTraq ID: 53548
http://www.securityfocus.com/bid/53548
http://www.gentoo.org/security/en/glsa/glsa-201206-20.xml
http://git.gnome.org/browse/gdk-pixbuf/
https://bugs.launchpad.net/ubuntu/+source/gdk-pixbuf/+bug/681150
http://www.openwall.com/lists/oss-security/2012/05/15/8
http://www.openwall.com/lists/oss-security/2012/05/15/9
RedHat Security Advisories: RHSA-2013:0135
http://rhn.redhat.com/errata/RHSA-2013-0135.html
http://secunia.com/advisories/49125
http://secunia.com/advisories/49715
XForce ISS Database: gdkpixbuf-readbitmapfiledata-bo(75578)
https://exchange.xforce.ibmcloud.com/vulnerabilities/75578




© 1998-2021 E-Soft Inc. All rights reserved.