Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

CVE ID:CVE-2009-0642
Description:ext/openssl/ossl_ocsp.c in Ruby 1.8 and 1.9 does not properly check the return value from the OCSP_basic_verify function, which might allow remote attackers to successfully present an invalid X.509 certificate, possibly involving a revoked certificate.
Test IDs: 1.3.6.1.4.1.25623.1.0.64536   1.3.6.1.4.1.25623.1.0.64639  
Cross References: Common Vulnerability Exposure (CVE) ID: CVE-2009-0642
BugTraq ID: 33769
http://www.securityfocus.com/bid/33769
http://www.mandriva.com/security/advisories?name=MDVSA-2009:193
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=513528
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11450
RedHat Security Advisories: RHSA-2009:1140
http://www.redhat.com/support/errata/RHSA-2009-1140.html
http://www.securitytracker.com/id?1022505
http://secunia.com/advisories/33750
http://secunia.com/advisories/35699
http://secunia.com/advisories/35937
http://www.ubuntu.com/usn/USN-805-1
XForce ISS Database: ruby-ocspbasicverify-spoofing(48761)
https://exchange.xforce.ibmcloud.com/vulnerabilities/48761




© 1998-2021 E-Soft Inc. All rights reserved.