Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.902715
Category:Mac OS X Local Security Checks
Title:Apple Mac OS X PackageKit Format String Vulnerability
Summary:This host is missing an important security update according to; Mac OS X 10.6.6 Update.
Description:Summary:
This host is missing an important security update according to
Mac OS X 10.6.6 Update.

Vulnerability Insight:
The flaw is due to a format string error in PackageKit's handling of
distribution scripts. A man-in-the-middle attacker may be able to cause an unexpected application termination
or arbitrary code execution when the Software Update checks for new updates.

Vulnerability Impact:
Successful exploitation could allow attackers to cause an unexpected
application termination or arbitrary code execution.

Affected Software/OS:
Mac OS X version 10.6 through 10.6.5

Mac OS X Server version 10.6 through 10.6.5.

Solution:
Upgrade to Mac OS X/Server version 10.6.6 or later.

CVSS Score:
6.8

CVSS Vector:
AV:N/AC:M/Au:N/C:P/I:P/A:P

Cross-Ref: BugTraq ID: 45693
Common Vulnerability Exposure (CVE) ID: CVE-2010-4013
http://lists.apple.com/archives/security-announce/2011//Jan/msg00000.html
http://osvdb.org/70309
http://www.securitytracker.com/id?1024938
http://secunia.com/advisories/42841
http://www.vupen.com/english/advisories/2011/0050
CopyrightCopyright (C) 2011 Greenbone Networks GmbH

This is only one of 99761 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.