Vulnerability   
Search   
    Search 191973 CVE descriptions
and 86218 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.892417
Category:Debian Local Security Checks
Title:Debian LTS: Security Advisory for linux-4.19 (DLA-2417-1)
Summary:The remote host is missing an update for the 'linux-4.19'; package(s) announced via the DLA-2417-1 advisory.
Description:Summary:
The remote host is missing an update for the 'linux-4.19'
package(s) announced via the DLA-2417-1 advisory.

Vulnerability Insight:
Several vulnerabilities have been discovered in the Linux kernel that
may lead to the execution of arbitrary code, privilege escalation,
denial of service or information leaks.

CVE-2020-12351

Andy Nguyen discovered a flaw in the Bluetooth implementation in the
way L2CAP packets with A2MP CID are handled. A remote attacker in
short distance knowing the victim's Bluetooth device address can
send a malicious l2cap packet and cause a denial of service or
possibly arbitrary code execution with kernel privileges.

CVE-2020-12352

Andy Nguyen discovered a flaw in the Bluetooth implementation. Stack
memory is not properly initialised when handling certain AMP
packets. A remote attacker in short distance knowing the victim's
Bluetooth device address address can retrieve kernel stack
information.

CVE-2020-25211

A flaw was discovered in netfilter subsystem. A local attacker
able to inject conntrack Netlink configuration can cause a denial
of service.

CVE-2020-25643

ChenNan Of Chaitin Security Research Lab discovered a flaw in the
hdlc_ppp module. Improper input validation in the ppp_cp_parse_cr()
function may lead to memory corruption and information disclosure.

CVE-2020-25645

A flaw was discovered in the interface driver for GENEVE
encapsulated traffic when combined with IPsec. If IPsec is
configured to encrypt traffic for the specific UDP port used by the
GENEVE tunnel, tunneled data isn't correctly routed over the
encrypted link and sent unencrypted instead.

Affected Software/OS:
'linux-4.19' package(s) on Debian Linux.

Solution:
For Debian 9 stretch, these problems have been fixed in version
4.19.152-1~
deb9u1.

We recommend that you upgrade your linux-4.19 packages.

CVSS Score:
7.5

CVSS Vector:
AV:N/AC:M/Au:S/C:P/I:P/A:C

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-12351
Common Vulnerability Exposure (CVE) ID: CVE-2020-12352
Common Vulnerability Exposure (CVE) ID: CVE-2020-25211
Common Vulnerability Exposure (CVE) ID: CVE-2020-25643
Common Vulnerability Exposure (CVE) ID: CVE-2020-25645
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 86218 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.