Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.871860
Category:Red Hat Local Security Checks
Title:RedHat Update for git RHSA-2017:2004-01
Summary:The remote host is missing an update for the 'git'; package(s) announced via the referenced advisory.
Description:Summary:
The remote host is missing an update for the 'git'
package(s) announced via the referenced advisory.

Vulnerability Insight:
Git is a distributed revision control system
with a decentralized architecture. As opposed to centralized version control
systems with a client-server model, Git ensures that each working copy of a Git
repository is an exact copy with complete revision history. This not only allows
the user to work on and contribute to projects without the need to have
permission to push the changes to their official repositories, but also makes it
possible for the user to work with no network connection. Security Fix(es): * It
was found that the git-prompt.sh script shipped with git failed to correctly
handle branch names containing special characters. A specially crafted git
repository could use this flaw to execute arbitrary commands if a user working
with the repository configured their shell to include repository information in
the prompt. (CVE-2014-9938) * A flaw was found in the way git-shell handled
command-line options for the restricted set of git-shell commands. A remote,
authenticated attacker could use this flaw to bypass git-shell restrictions, to
view and manipulate files, by abusing the instance of the less command launched
using crafted command-line options. (CVE-2017-8386) Additional Changes: For
detailed information on changes in this release, see the Red Hat Enterprise
Linux 7.4 Release Notes linked from the References section.

Affected Software/OS:
git on Red Hat Enterprise Linux Server (v. 7)

Solution:
Please Install the Updated Packages.

CVSS Score:
6.8

CVSS Vector:
AV:N/AC:M/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2014-9938
https://github.com/njhartwell/pw3nage
RedHat Security Advisories: RHSA-2017:2004
https://access.redhat.com/errata/RHSA-2017:2004
Common Vulnerability Exposure (CVE) ID: CVE-2017-8386
BugTraq ID: 98409
http://www.securityfocus.com/bid/98409
Debian Security Information: DSA-3848 (Google Search)
http://www.debian.org/security/2017/dsa-3848
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3ISHYFLM2ACYHHY3JHCLF75X7UF4ZMDM/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FDS3LSJJ3YGGQYIVPKQDVOCXWDSF6JGF/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DPYRN7APMHY4ZFDPAKD22J5R4QJFY2JP/
https://security.gentoo.org/glsa/201706-04
https://insinuator.net/2017/05/git-shell-bypass-by-abusing-less-cve-2017-8386/
http://public-inbox.org/git/xmqq8tm5ziat.fsf@gitster.mtv.corp.google.com/
RedHat Security Advisories: RHSA-2017:2491
https://access.redhat.com/errata/RHSA-2017:2491
http://www.securitytracker.com/id/1038479
SuSE Security Announcement: openSUSE-SU-2017:1422 (Google Search)
http://lists.opensuse.org/opensuse-updates/2017-05/msg00090.html
http://www.ubuntu.com/usn/USN-3287-1
Common Vulnerability Exposure (CVE) ID: CVE-2011-2192
http://lists.apple.com/archives/security-announce/2012/Feb/msg00000.html
Debian Security Information: DSA-2271 (Google Search)
http://www.debian.org/security/2011/dsa-2271
http://lists.fedoraproject.org/pipermail/package-announce/2011-June/061992.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-July/062287.html
http://security.gentoo.org/glsa/glsa-201203-02.xml
http://www.mandriva.com/security/advisories?name=MDVSA-2011:116
http://www.redhat.com/support/errata/RHSA-2011-0918.html
http://www.securitytracker.com/id?1025713
http://secunia.com/advisories/45047
http://secunia.com/advisories/45067
http://secunia.com/advisories/45088
http://secunia.com/advisories/45144
http://secunia.com/advisories/45181
http://secunia.com/advisories/48256
http://www.ubuntu.com/usn/USN-1158-1
CopyrightCopyright (C) 2017 Greenbone Networks GmbH

This is only one of 99761 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.