Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.871485
Category:Red Hat Local Security Checks
Title:RedHat Update for cups-filters RHSA-2015:2360-01
Summary:The remote host is missing an update for the 'cups-filters'; package(s) announced via the referenced advisory.
Description:Summary:
The remote host is missing an update for the 'cups-filters'
package(s) announced via the referenced advisory.

Vulnerability Insight:
The cups-filters packages contain back ends,
filters, and other software that was once part of the core Common UNIX Printing
System (CUPS) distribution but is now maintained independently.

A heap-based buffer overflow flaw and an integer overflow flaw leading to a
heap-based buffer overflow were discovered in the way the texttopdf utility
of cups-filter processed print jobs with a specially crafted line size.
An attacker able to submit print jobs could use these flaws to crash
texttopdf or, possibly, execute arbitrary code with the privileges of the
'lp' user. (CVE-2015-3258, CVE-2015-3279)

The CVE-2015-3258 issue was discovered by Petr Sklenar of Red Hat.

Notably, this update also fixes the following bug:

* Previously, when polling CUPS printers from a CUPS server, when a printer
name contained an underscore (_), the client displayed the name containing
a hyphen (-) instead. This made the print queue unavailable. With this
update, CUPS allows the underscore character in printer names, and printers
appear as shown on the CUPS server as expected. (BZ#1167408)

In addition, this update adds the following enhancement:

* Now, the information from local and remote CUPS servers is cached during
each poll, and the CUPS server load is reduced. (BZ#1191691)

All cups-filters users are advised to upgrade to these updated packages,
which contain backported patches to correct these issues and add this
enhancement.

Affected Software/OS:
cups-filters on Red Hat Enterprise Linux Server (v. 7)

Solution:
Please Install the Updated Packages.

CVSS Score:
7.5

CVSS Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2015-3258
BugTraq ID: 75436
http://www.securityfocus.com/bid/75436
Debian Security Information: DSA-3303 (Google Search)
http://www.debian.org/security/2015/dsa-3303
https://security.gentoo.org/glsa/201510-08
http://www.openwall.com/lists/oss-security/2015/06/26/4
RedHat Security Advisories: RHSA-2015:2360
http://rhn.redhat.com/errata/RHSA-2015-2360.html
SuSE Security Announcement: openSUSE-SU-2015:1244 (Google Search)
http://lists.opensuse.org/opensuse-updates/2015-07/msg00033.html
http://ubuntu.com/usn/usn-2659-1
Common Vulnerability Exposure (CVE) ID: CVE-2015-3279
BugTraq ID: 75557
http://www.securityfocus.com/bid/75557
http://www.openwall.com/lists/oss-security/2015/07/03/2
http://www.openwall.com/lists/oss-security/2015/07/03/5
CopyrightCopyright (C) 2015 Greenbone Networks GmbH

This is only one of 99761 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.