Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.871123
Category:Red Hat Local Security Checks
Title:RedHat Update for pidgin RHSA-2014:0139-01
Summary:The remote host is missing an update for the 'pidgin'; package(s) announced via the referenced advisory.
Description:Summary:
The remote host is missing an update for the 'pidgin'
package(s) announced via the referenced advisory.

Vulnerability Insight:
Pidgin is an instant messaging program which can log in to multiple
accounts on multiple instant messaging networks simultaneously.

A heap-based buffer overflow flaw was found in the way Pidgin processed
certain HTTP responses. A malicious server could send a specially crafted
HTTP response, causing Pidgin to crash or potentially execute arbitrary
code with the permissions of the user running Pidgin. (CVE-2013-6485)

Multiple heap-based buffer overflow flaws were found in several protocol
plug-ins in Pidgin (Gadu-Gadu, MXit, SIMPLE). A malicious server could send
a specially crafted message, causing Pidgin to crash or potentially execute
arbitrary code with the permissions of the user running Pidgin.
(CVE-2013-6487, CVE-2013-6489, CVE-2013-6490)

Multiple denial of service flaws were found in several protocol plug-ins in
Pidgin (Yahoo!, XMPP, MSN, stun, IRC). A remote attacker could use these
flaws to crash Pidgin by sending a specially crafted message.
(CVE-2012-6152, CVE-2013-6477, CVE-2013-6481, CVE-2013-6482, CVE-2013-6484,
CVE-2014-0020)

It was found that the Pidgin XMPP protocol plug-in did not verify the
origin of 'iq' replies. A remote attacker could use this flaw to spoof an
'iq' reply, which could lead to injection of fake data or cause Pidgin to
crash via a NULL pointer dereference. (CVE-2013-6483)

A flaw was found in the way Pidgin parsed certain HTTP response headers.
A remote attacker could use this flaw to crash Pidgin via a specially
crafted HTTP response header. (CVE-2013-6479)

It was found that Pidgin crashed when a mouse pointer was hovered over a
long URL. A remote attacker could use this flaw to crash Pidgin by sending
a message containing a long URL string. (CVE-2013-6478)

Red Hat would like to thank the Pidgin project for reporting these issues.
Upstream acknowledges Thijs Alkemade, Robert Vehse, Jaime Breva Ribes,
Jacob Appelbaum of the Tor Project, Daniel Atallah, Fabian Yamaguchi and
Christian Wressnegger of the University of Goettingen, Matt Jones of
Volvent, and Yves Younan, Ryan Pentney, and Pawel Janic of Sourcefire VRT
as the original reporters of these issues.

All pidgin users are advised to upgrade to these updated packages, which
contain backported patches to correct these issues. Pidgin must be
restarted for this update to take effect.

Affected Software/OS:
pidgin on Red Hat Enterprise Linux Desktop (v. 6),
Red Hat Enterprise Linux Workstation (v. 6)

Solution:
Please Install the Updated Packages.

CVSS Score:
10.0

CVSS Vector:
AV:N/AC:L/Au:N/C:C/I:C/A:C

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2012-6152
RedHat Security Advisories: RHSA-2014:0139
https://rhn.redhat.com/errata/RHSA-2014-0139.html
SuSE Security Announcement: openSUSE-SU-2014:0239 (Google Search)
http://lists.opensuse.org/opensuse-updates/2014-02/msg00039.html
SuSE Security Announcement: openSUSE-SU-2014:0326 (Google Search)
http://lists.opensuse.org/opensuse-updates/2014-03/msg00005.html
http://www.ubuntu.com/usn/USN-2100-1
Common Vulnerability Exposure (CVE) ID: CVE-2013-6477
Debian Security Information: DSA-2859 (Google Search)
http://www.debian.org/security/2014/dsa-2859
Common Vulnerability Exposure (CVE) ID: CVE-2013-6478
http://pidgin.im/pipermail/support/2013-March/012980.html
http://pidgin.im/pipermail/support/2013-March/012981.html
Common Vulnerability Exposure (CVE) ID: CVE-2013-6479
Common Vulnerability Exposure (CVE) ID: CVE-2013-6481
Common Vulnerability Exposure (CVE) ID: CVE-2013-6482
Common Vulnerability Exposure (CVE) ID: CVE-2013-6483
Common Vulnerability Exposure (CVE) ID: CVE-2013-6484
Common Vulnerability Exposure (CVE) ID: CVE-2013-6485
BugTraq ID: 65243
http://www.securityfocus.com/bid/65243
Common Vulnerability Exposure (CVE) ID: CVE-2013-6487
BugTraq ID: 65188
http://www.securityfocus.com/bid/65188
Debian Security Information: DSA-2852 (Google Search)
http://www.debian.org/security/2014/dsa-2852
http://lists.fedoraproject.org/pipermail/package-announce/2014-February/128277.html
https://security.gentoo.org/glsa/201508-02
http://www.mandriva.com/security/advisories?name=MDVSA-2014:039
http://libgadu.net/releases/1.11.3.html
http://vrt-blog.snort.org/2014/01/vrt-2013-1001-cve-2013-6487-buffer.html
http://www.ubuntu.com/usn/USN-2101-1
Common Vulnerability Exposure (CVE) ID: CVE-2013-6489
BugTraq ID: 65192
http://www.securityfocus.com/bid/65192
http://hg.pidgin.im/pidgin/main/rev/4c897372b5a4
Common Vulnerability Exposure (CVE) ID: CVE-2013-6490
BugTraq ID: 65195
http://www.securityfocus.com/bid/65195
Common Vulnerability Exposure (CVE) ID: CVE-2014-0020
CopyrightCopyright (C) 2014 Greenbone Networks GmbH

This is only one of 99761 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.