Vulnerability   
Search   
    Search 187964 CVE descriptions
and 85075 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.844629
Category:Ubuntu Local Security Checks
Title:Ubuntu: Security Advisory for ruby-rack (USN-4561-1)
Summary:The remote host is missing an update for the 'ruby-rack'; package(s) announced via the USN-4561-1 advisory.
Description:Summary:
The remote host is missing an update for the 'ruby-rack'
package(s) announced via the USN-4561-1 advisory.

Vulnerability Insight:
It was discovered that Rack incorrectly handled certain paths. An attacker
could possibly use this issue to obtain sensitive information.
(CVE-2020-8161)

It was discovered that Rack incorrectly validated cookies. An attacker
could possibly use this issue to forge a secure cookie. (CVE-2020-8184)

Affected Software/OS:
'ruby-rack' package(s) on Ubuntu 18.04 LTS.

Solution:
Please install the updated package(s).

CVSS Score:
5.0

CVSS Vector:
AV:N/AC:L/Au:N/C:P/I:N/A:N

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-8161
https://groups.google.com/g/rubyonrails-security/c/IOO1vNZTzPA
https://hackerone.com/reports/434404
https://lists.debian.org/debian-lts-announce/2020/07/msg00006.html
Common Vulnerability Exposure (CVE) ID: CVE-2020-8184
https://groups.google.com/g/rubyonrails-security/c/OWtmozPH9Ak
https://hackerone.com/reports/895727
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 85075 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.