Vulnerability   
Search   
    Search 187964 CVE descriptions
and 85075 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.844616
Category:Ubuntu Local Security Checks
Title:Ubuntu: Security Advisory for gnuplot (USN-4541-1)
Summary:The remote host is missing an update for the 'gnuplot'; package(s) announced via the USN-4541-1 advisory.
Description:Summary:
The remote host is missing an update for the 'gnuplot'
package(s) announced via the USN-4541-1 advisory.

Vulnerability Insight:
Tim Blazytko, Cornelius Aschermann, Sergej Schumilo and Nils Bars
discovered that Gnuplot did not properly validate string sizes in the
df_generate_ascii_array_entry function. An attacker could possibly use
this issue to cause a heap buffer overflow, resulting in a denial of
service attack or arbitrary code execution. (CVE-2018-19490)

Tim Blazytko, Cornelius Aschermann, Sergej Schumilo and Nils Bars
discovered that Gnuplot did not properly validate string sizes in the
PS_options function when the Gnuplot postscript terminal is used as a
backend. An attacker could possibly use this issue to cause a buffer
overflow, resulting in a denial of service attack or arbitrary code
execution. (CVE-2018-19491)

Tim Blazytko, Cornelius Aschermann, Sergej Schumilo and Nils Bars
discovered that Gnuplot did not properly validate string sizes in the
cairotrm_options function when the Gnuplot postscript terminal is used
as a backend. An attacker could possibly use this issue to cause a
buffer overflow, resulting in a denial of service attack or arbitrary
code execution. (CVE-2018-19492)

Affected Software/OS:
'gnuplot' package(s) on Ubuntu 16.04 LTS.

Solution:
Please install the updated package(s).

CVSS Score:
6.8

CVSS Vector:
AV:N/AC:M/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2018-19490
Common Vulnerability Exposure (CVE) ID: CVE-2018-19491
Common Vulnerability Exposure (CVE) ID: CVE-2018-19492
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 85075 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.