Vulnerability   
Search   
    Search 187964 CVE descriptions
and 85075 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.844600
Category:Ubuntu Local Security Checks
Title:Ubuntu: Security Advisory for netty-3.9 (USN-4532-1)
Summary:The remote host is missing an update for the 'netty-3.9'; package(s) announced via the USN-4532-1 advisory.
Description:Summary:
The remote host is missing an update for the 'netty-3.9'
package(s) announced via the USN-4532-1 advisory.

Vulnerability Insight:
It was discovered that Netty incorrectly handled certain HTTP headers.
By sending an HTTP header with whitespace before the colon, a remote
attacker could possibly use this issue to perform an HTTP request
smuggling attack. (CVE-2019-16869)

It was discovered that Netty incorrectly handled certain HTTP headers.
By sending an HTTP header that lacks a colon, a remote attacker could
possibly use this issue to perform an HTTP request smuggling attack.
(CVE-2019-20444)

It was discovered that Netty incorrectly handled certain HTTP headers.
By sending a Content-Length header accompanied by a second
Content-Length header, or by a Transfer-Encoding header, a remote
attacker could possibly use this issue to perform an HTTP request
smuggling attack. (CVE-2019-20445)

Affected Software/OS:
'netty-3.9' package(s) on Ubuntu 18.04 LTS.

Solution:
Please install the updated package(s).

CVSS Score:
6.4

CVSS Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:N

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2019-16869
Common Vulnerability Exposure (CVE) ID: CVE-2019-20444
Common Vulnerability Exposure (CVE) ID: CVE-2019-20445
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 85075 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.