English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 72151 CVE descriptions
and 38907 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.71049
Category:Ubuntu Local Security Checks
Title:Ubuntu USN-1317-1 (libgs8)
Summary:Ubuntu USN-1317-1 (libgs8)
Description:The remote host is missing an update to libgs8
announced via advisory USN-1317-1.

Details:

It was discovered that Ghostscript did not correctly handle memory
allocation when parsing certain malformed JPEG-2000 images. If a user or
automated system were tricked into opening a specially crafted image, an
attacker could cause a denial of service and possibly execute arbitrary
code with user privileges. (CVE-2008-3520)

It was discovered that Ghostscript did not correctly handle certain
formatting operations when parsing JPEG-2000 images. If a user or automated
system were tricked into opening a specially crafted image, an attacker
could cause a denial of service and possibly execute arbitrary code with
user privileges. (CVE-2008-3522)

It was discovered that Ghostscript incorrectly handled certain malformed
TrueType fonts. If a user or automated system were tricked into opening a
document containing a specially crafted font, an attacker could cause a
denial of service and possibly execute arbitrary code with user privileges.
This issue only affected Ubuntu 8.04 LTS. (CVE-2009-3743)

It was discovered that Ghostscript incorrectly handled certain malformed
Type 2 fonts. If a user or automated system were tricked into opening a
document containing a specially crafted font, an attacker could cause a
denial of service and possibly execute arbitrary code with user privileges.
This issue only affected Ubuntu 8.04 LTS. (CVE-2010-4054)

Jonathan Foote discovered that Ghostscript incorrectly handled certain
malformed JPEG-2000 image files. If a user or automated system were tricked
into opening a specially crafted JPEG-2000 image file, an attacker could
cause Ghostscript to crash or possibly execute arbitrary code with user
privileges. (CVE-2011-4516, CVE-2011-4517)

Solution:
The problem can be corrected by updating your system to the following
package versions:

Ubuntu 10.10:
libgs8 8.71.dfsg.2-0ubuntu7.1

Ubuntu 10.04 LTS:
libgs8 8.71.dfsg.1-0ubuntu5.4

Ubuntu 8.04 LTS:
libgs8 8.61.dfsg.1-1ubuntu3.4

http://www.securityspace.com/smysecure/catid.html?in=USN-1317-1
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2008-3520
http://bugs.gentoo.org/show_bug.cgi?id=222819
http://security.gentoo.org/glsa/glsa-200812-18.xml
http://www.mandriva.com/security/advisories?name=MDVSA-2009:142
http://www.mandriva.com/security/advisories?name=MDVSA-2009:144
http://www.mandriva.com/security/advisories?name=MDVSA-2009:164
http://www.redhat.com/support/errata/RHSA-2009-0012.html
http://www.ubuntu.com/usn/USN-742-1
BugTraq ID: 31470
http://www.securityfocus.com/bid/31470
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10141
http://secunia.com/advisories/33173
http://secunia.com/advisories/34391
XForce ISS Database: jasper-image-file-bo(45621)
http://xforce.iss.net/xforce/xfdb/45621
Common Vulnerability Exposure (CVE) ID: CVE-2008-3522
http://bugs.gentoo.org/attachment.cgi?id=163282&action=view
XForce ISS Database: jasper-jasstreamprintf-bo(45623)
http://xforce.iss.net/xforce/xfdb/45623
Common Vulnerability Exposure (CVE) ID: CVE-2009-3743
Bugtraq: 20101125 TSSA-2010-01 Ghostscript library Ins_MINDEX() integer overflow and heap corruption (Google Search)
http://www.securityfocus.com/archive/1/archive/1/514892/100/0/threaded
http://www.kb.cert.org/vuls/id/JALR-87YGN8
CERT/CC vulnerability note: VU#644319
http://www.kb.cert.org/vuls/id/644319
http://www.securitytracker.com/id?1024785
Common Vulnerability Exposure (CVE) ID: CVE-2010-4054
http://ghostscript.com/pipermail/gs-cvs/2010-January/010333.html
CERT/CC vulnerability note: VU#538191
http://www.kb.cert.org/vuls/id/538191
Common Vulnerability Exposure (CVE) ID: CVE-2011-4516
Debian Security Information: DSA-2371 (Google Search)
http://www.debian.org/security/2011/dsa-2371
http://lists.fedoraproject.org/pipermail/package-announce/2012-January/071561.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-December/071458.html
http://www.redhat.com/support/errata/RHSA-2011-1811.html
http://www.redhat.com/support/errata/RHSA-2011-1807.html
SuSE Security Announcement: openSUSE-SU-2011:1317 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2011-12/msg00010.html
http://www.ubuntu.com/usn/USN-1315-1
CERT/CC vulnerability note: VU#887409
http://www.kb.cert.org/vuls/id/887409
http://osvdb.org/77595
http://secunia.com/advisories/47306
http://secunia.com/advisories/47353
http://secunia.com/advisories/47193
Common Vulnerability Exposure (CVE) ID: CVE-2011-4517
http://osvdb.org/77596
XForce ISS Database: jasper-jpccrggetparms-bo(71701)
http://xforce.iss.net/xforce/xfdb/71701
CopyrightCopyright (c) 2012 E-Soft Inc. http://www.securityspace.com

This is only one of 38907 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.