English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 75516 CVE descriptions
and 39786 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.64444
Category:Ubuntu Local Security Checks
Title:Ubuntu USN-803-1 (dhcp3)
Summary:Ubuntu USN-803-1 (dhcp3)
Description:The remote host is missing an update to dhcp3
announced via advisory USN-803-1.

Details follow:

It was discovered that the DHCP client as included in dhcp3 did not verify
the length of certain option fields when processing a response from an IPv4
dhcp server. If a user running Ubuntu 6.06 LTS or 8.04 LTS connected to a
malicious dhcp server, a remote attacker could cause a denial of service or
execute arbitrary code as the user invoking the program, typically the
'dhcp' user. For users running Ubuntu 8.10 or 9.04, a remote attacker
should only be able to cause a denial of service in the DHCP client. In
Ubuntu 9.04, attackers would also be isolated by the AppArmor dhclient3
profile.

Solution:
The problem can be corrected by upgrading your system to the
following package versions:

Ubuntu 6.06 LTS:
dhcp3-client 3.0.3-6ubuntu7.1
dhcp3-client-udeb 3.0.3-6ubuntu7.1

Ubuntu 8.04 LTS:
dhcp3-client 3.0.6.dfsg-1ubuntu9.1
dhcp3-client-udeb 3.0.6.dfsg-1ubuntu9.1

Ubuntu 8.10:
dhcp3-client 3.1.1-1ubuntu2.1
dhcp3-client-udeb 3.1.1-1ubuntu2.1

Ubuntu 9.04:
dhcp3-client 3.1.1-5ubuntu8.1
dhcp3-client-udeb 3.1.1-5ubuntu8.1

After a standard system upgrade you need to restart any DHCP network
connections utilizing dhclient3 to effect the necessary changes.

http://www.securityspace.com/smysecure/catid.html?in=USN-803-1
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2009-0692
Debian Security Information: DSA-1833 (Google Search)
http://www.debian.org/security/2009/dsa-1833
https://www.redhat.com/archives/fedora-package-announce/2009-August/msg01177.html
https://www.redhat.com/archives/fedora-package-announce/2009-November/msg00340.html
http://security.gentoo.org/glsa/glsa-200907-12.xml
HPdes Security Advisory: HPSBMA02554
http://itrc.hp.com/service/cki/docDisplay.do?docId=emr_na-c02286083
HPdes Security Advisory: SSRT100018
http://www.mandriva.com/security/advisories?name=MDVSA-2009:151
NETBSD Security Advisory: NetBSD-SA2009-010
http://ftp.netbsd.org/pub/NetBSD/security/advisories/NetBSD-SA2009-010.txt.asc
http://www.redhat.com/support/errata/RHSA-2009-1136.html
http://www.redhat.com/support/errata/RHSA-2009-1154.html
http://slackware.com/security/viewer.php?l=slackware-security&y=2009&m=slackware-security.561471
SuSE Security Announcement: SUSE-SA:2009:037 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2009-07/msg00003.html
http://www.ubuntu.com/usn/usn-803-1
CERT/CC vulnerability note: VU#410676
http://www.kb.cert.org/vuls/id/410676
BugTraq ID: 35668
http://www.securityfocus.com/bid/35668
http://www.osvdb.org/55819
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10758
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:5941
http://www.securitytracker.com/id?1022548
http://secunia.com/advisories/35785
http://secunia.com/advisories/35829
http://secunia.com/advisories/35830
http://secunia.com/advisories/35831
http://secunia.com/advisories/35832
http://secunia.com/advisories/35841
http://secunia.com/advisories/35849
http://secunia.com/advisories/35850
http://secunia.com/advisories/35851
http://secunia.com/advisories/35880
http://secunia.com/advisories/36457
http://secunia.com/advisories/37342
http://secunia.com/advisories/40551
http://www.vupen.com/english/advisories/2009/1891
http://www.vupen.com/english/advisories/2010/1796
CopyrightCopyright (c) 2009 E-Soft Inc. http://www.securityspace.com

This is only one of 39786 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.