English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 76783 CVE descriptions
and 40246 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.64367
Category:Ubuntu Local Security Checks
Title:Ubuntu USN-794-1 (perl)
Summary:Ubuntu USN-794-1 (perl)
Description:The remote host is missing an update to perl
announced via advisory USN-794-1.

Details follow:

It was discovered that the Compress::Raw::Zlib Perl module incorrectly
handled certain zlib compressed streams. If a user or automated system were
tricked into processing a specially crafted compressed stream or file, a
remote attacker could crash the application, leading to a denial of
service.

Solution:
The problem can be corrected by upgrading your system to the
following package versions:

Ubuntu 8.04 LTS:
libcompress-raw-zlib-perl 2.008-1ubuntu0.1

Ubuntu 8.10:
libcompress-raw-zlib-perl 2.011-2ubuntu0.1
perl 5.10.0-11.1ubuntu2.3

Ubuntu 9.04:
libcompress-raw-zlib-perl 2.015-1ubuntu0.1
perl 5.10.0-19ubuntu1.1

In general, a standard system upgrade is sufficient to effect the
necessary changes.

http://www.securityspace.com/smysecure/catid.html?in=USN-794-1
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2009-1391
http://article.gmane.org/gmane.mail.virus.amavis.user/33635
http://article.gmane.org/gmane.mail.virus.amavis.user/33638
http://thread.gmane.org/gmane.mail.virus.amavis.user/33635
https://www.redhat.com/archives/fedora-package-announce/2009-July/msg00607.html
http://security.gentoo.org/glsa/glsa-200908-07.xml
http://www.mandriva.com/security/advisories?name=MDVSA-2009:157
SuSE Security Announcement: SUSE-SR:2009:012 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2009-07/msg00002.html
http://www.ubuntulinux.org/support/documentation/usn/usn-794-1
BugTraq ID: 35307
http://www.securityfocus.com/bid/35307
http://osvdb.org/55041
http://secunia.com/advisories/35422
http://secunia.com/advisories/35685
http://secunia.com/advisories/35689
http://secunia.com/advisories/35876
http://www.vupen.com/english/advisories/2009/1571
XForce ISS Database: perl-compressrawzlib-inflate-bo(51062)
http://xforce.iss.net/xforce/xfdb/51062
CopyrightCopyright (c) 2009 E-Soft Inc. http://www.securityspace.com

This is only one of 40246 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.