English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 61204 CVE descriptions
and 32582 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.63896
Category:Ubuntu Local Security Checks
Title:Ubuntu USN-761-1 (php5)
Summary:Ubuntu USN-761-1 (php5)
Description:The remote host is missing an update to php5
announced via advisory USN-761-1.

Details follow:

It was discovered that PHP did not sanitize certain error messages when
display_errors is enabled, which could result in browsers becoming
vulnerable to cross-site scripting attacks when processing the output. With
cross-site scripting vulnerabilities, if a user were tricked into viewing
server output during a crafted server request, a remote attacker could
exploit this to modify the contents, or steal confidential data (such as
passwords), within the same domain. (CVE-2008-5814)

It was discovered that PHP did not properly handle the
mbstring.func_overload setting within .htaccess files when using virtual
hosts. A virtual host administrator could use this flaw to cause settings
to be applied to other virtual hosts on the same server. (CVE-2009-0754)

It was discovered that PHP did not properly handle certain malformed
strings when being parsed by the json_decode function. A remote attacker
could exploit this flaw and cause the PHP server to crash, resulting in a
denial of service. This issue only affected Ubuntu 8.04 and 8.10.
(CVE-2009-1271)

Solution:
The problem can be corrected by upgrading your system to the
following package versions:

Ubuntu 6.06 LTS:
libapache2-mod-php5 5.1.2-1ubuntu3.14
php5-cgi 5.1.2-1ubuntu3.14
php5-cli 5.1.2-1ubuntu3.14

Ubuntu 8.04 LTS:
libapache2-mod-php5 5.2.4-2ubuntu5.6
php5-cgi 5.2.4-2ubuntu5.6
php5-cli 5.2.4-2ubuntu5.6

Ubuntu 8.10:
libapache2-mod-php5 5.2.6-2ubuntu4.2
php5-cgi 5.2.6-2ubuntu4.2
php5-cli 5.2.6-2ubuntu4.2

In general, a standard system upgrade is sufficient to effect the
necessary changes.

http://www.securityspace.com/smysecure/catid.html?in=USN-761-1
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2008-5814
Debian Security Information: DSA-1789 (Google Search)
http://www.debian.org/security/2009/dsa-1789
HPdes Security Advisory: HPSBMA02426
http://marc.info/?l=bugtraq&m=124277349419254&w=2
HPdes Security Advisory: SSRT090053
HPdes Security Advisory: HPSBMA02492
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c02029444
HPdes Security Advisory: SSRT100079
http://www.redhat.com/support/errata/RHSA-2009-0350.html
http://www.ubuntulinux.org/support/documentation/usn/usn-761-1
http://www.ubuntu.com/usn/USN-761-2
http://jvn.jp/en/jp/JVN50327700/index.html
http://jvndb.jvn.jp/en/contents/2008/JVNDB-2008-000084.html
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10501
http://secunia.com/advisories/34830
http://secunia.com/advisories/34933
http://secunia.com/advisories/35003
http://secunia.com/advisories/35007
http://secunia.com/advisories/35108
http://www.vupen.com/english/advisories/2009/1338
XForce ISS Database: php-directives-xss(47496)
http://xforce.iss.net/xforce/xfdb/47496
Common Vulnerability Exposure (CVE) ID: CVE-2009-0754
http://www.openwall.com/lists/oss-security/2009/01/30/1
http://www.openwall.com/lists/oss-security/2009/02/03/3
http://www.openwall.com/lists/oss-security/2009/02/25/3
https://www.redhat.com/archives/fedora-package-announce/2009-May/msg01451.html
https://www.redhat.com/archives/fedora-package-announce/2009-May/msg01465.html
SuSE Security Announcement: SUSE-SR:2009:008 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2009-04/msg00003.html
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11035
http://www.securitytracker.com/id?1021979
http://secunia.com/advisories/34642
http://secunia.com/advisories/35306
Common Vulnerability Exposure (CVE) ID: CVE-2009-1271
http://www.openwall.com/lists/oss-security/2009/04/01/9
http://cvs.php.net/viewvc.cgi/php-src/ext/json/JSON_parser.c?r1=1.1.2.14&r2=1.1.2.15
http://lists.apple.com/archives/security-announce/2009/Sep/msg00004.html
Debian Security Information: DSA-1775 (Google Search)
http://www.debian.org/security/2009/dsa-1775
http://www.mandriva.com/security/advisories?name=MDVSA-2009:090
SuSE Security Announcement: SUSE-SR:2009:012 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2009-07/msg00002.html
http://secunia.com/advisories/34770
http://secunia.com/advisories/35685
http://secunia.com/advisories/36701
Common Vulnerability Exposure (CVE) ID: CVE-2009-1300
http://www.openwall.com/lists/oss-security/2009/04/08/11
Debian Security Information: DSA-1779 (Google Search)
http://www.debian.org/security/2009/dsa-1779
http://www.ubuntulinux.org/support/documentation/usn/usn-762-1
http://secunia.com/advisories/34829
http://secunia.com/advisories/34832
http://secunia.com/advisories/34874
CopyrightCopyright (c) 2009 E-Soft Inc. http://www.securityspace.com

This is only one of 32582 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.