English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 72151 CVE descriptions
and 38907 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.61506
Category:Ubuntu Local Security Checks
Title:Ubuntu USN-631-1 (poppler)
Summary:Ubuntu USN-631-1 (poppler)
Description:
The remote host is missing an update to poppler
announced via advisory USN-631-1.

A security issue affects the following Ubuntu releases:

Ubuntu 7.10
Ubuntu 8.04 LTS

This advisory also applies to the corresponding versions of
Kubuntu, Edubuntu, and Xubuntu.

Details follow:

Felipe Andres Manzano discovered that poppler did not correctly initialize
certain page widgets. If a user were tricked into viewing a malicious
PDF file, a remote attacker could exploit this to crash applications
linked against poppler, leading to a denial of service.

Solution:
The problem can be corrected by upgrading your system to the
following package versions:

Ubuntu 7.10:
libpoppler2 0.6-0ubuntu2.3

Ubuntu 8.04 LTS:
libpoppler2 0.6.4-1ubuntu3.1

In general, a standard system upgrade is sufficient to effect the
necessary changes.

http://www.securityspace.com/smysecure/catid.html?in=USN-631-1

Risk factor : High
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2008-2950
Bugtraq: 20080707 [oCERT-2008-007] libpoppler uninitialized pointer (Google Search)
http://www.securityfocus.com/archive/1/archive/1/493980/100/0/threaded
Bugtraq: 20080709 rPSA-2008-0223-1 poppler (Google Search)
http://www.securityfocus.com/archive/1/archive/1/494142/100/0/threaded
http://www.milw0rm.com/exploits/6032
http://www.ocert.org/advisories/ocert-2008-007.html
https://www.redhat.com/archives/fedora-package-announce/2008-August/msg00161.html
http://security.gentoo.org/glsa/glsa-200807-04.xml
http://www.mandriva.com/security/advisories?name=MDVSA-2008:146
SuSE Security Announcement: SUSE-SR:2008:015 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2008-07/msg00006.html
http://www.ubuntu.com/usn/usn-631-1
BugTraq ID: 30107
http://www.securityfocus.com/bid/30107
http://secunia.com/advisories/31167
http://www.vupen.com/english/advisories/2008/2024/references
http://www.securitytracker.com/id?1020435
http://secunia.com/advisories/30963
http://secunia.com/advisories/31002
http://secunia.com/advisories/31267
http://secunia.com/advisories/31405
http://securityreason.com/securityalert/3977
XForce ISS Database: poppler-page-destructor-code-execution(43619)
http://xforce.iss.net/xforce/xfdb/43619
CopyrightCopyright (c) 2008 E-Soft Inc. http://www.securityspace.com

This is only one of 38907 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.