English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 73247 CVE descriptions
and 39212 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.60945
Category:Ubuntu Local Security Checks
Title:Ubuntu USN-609-1 (openoffice.org/-amd64)
Summary:Ubuntu USN-609-1 (openoffice.org/-amd64)
Description:
The remote host is missing an update to openoffice.org/-amd64
announced via advisory USN-609-1.

A security issue affects the following Ubuntu releases:

Ubuntu 6.06 LTS
Ubuntu 7.04
Ubuntu 7.10

This advisory also applies to the corresponding versions of
Kubuntu, Edubuntu, and Xubuntu.

Details follow:

It was discovered that arbitrary Java methods were not filtered out when
opening databases in OpenOffice.org. If a user were tricked into running
a specially crafted query, a remote attacker could execute arbitrary
Java with user privileges. (CVE-2007-4575)

Multiple memory overflow flaws were discovered in OpenOffice.org's
handling of Quattro Pro, EMF, and OLE files. If a user were tricked
into opening a specially crafted document, a remote attacker might be
able to execute arbitrary code with user privileges. (CVE-2007-5745,
CVE-2007-5746, CVE-2007-5747, CVE-2008-0320)

Solution:
The problem can be corrected by upgrading your system to the
following package versions:

Ubuntu 6.06 LTS:
libhsqldb-java 1.8.0.2-1ubuntu1.1
openoffice.org-core 2.0.2-2ubuntu12.6
openoffice.org2-base 2.0.2-2ubuntu12.6

Ubuntu 7.04:
libhsqldb-java 1.8.0.7-1ubuntu2.1
openoffice.org-core 2.2.0-1ubuntu6

Ubuntu 7.10:
libhsqldb-java 1.8.0.8-1ubuntu1.1
openoffice.org-core 1:2.3.0-1ubuntu5.4

After a standard system upgrade you need to restart OpenOffice.org to effect
the necessary changes.

http://www.securityspace.com/smysecure/catid.html?in=USN-609-1

Risk factor : Critical
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2007-4575
http://bugs.gentoo.org/show_bug.cgi?id=200771
http://bugs.gentoo.org/show_bug.cgi?id=201799
Debian Security Information: DSA-1419 (Google Search)
http://www.debian.org/security/2007/dsa-1419
https://www.redhat.com/archives/fedora-package-announce/2008-January/msg00753.html
http://www.redhat.com/archives/fedora-package-announce/2007-December/msg00134.html
https://www.redhat.com/archives/fedora-package-announce/2008-January/msg00678.html
http://www.redhat.com/archives/fedora-package-announce/2007-December/msg00155.html
http://www.redhat.com/archives/fedora-package-announce/2007-December/msg00281.html
http://www.gentoo.org/security/en/glsa/glsa-200712-25.xml
http://www.mandriva.com/security/advisories?name=MDVSA-2008:095
http://www.redhat.com/support/errata/RHSA-2007-1048.html
http://www.redhat.com/support/errata/RHSA-2007-1090.html
http://www.redhat.com/support/errata/RHSA-2008-0158.html
http://www.redhat.com/support/errata/RHSA-2008-0151.html
http://www.redhat.com/support/errata/RHSA-2008-0213.html
http://sunsolve.sun.com/search/document.do?assetkey=1-26-103141-1
http://sunsolve.sun.com/search/document.do?assetkey=1-66-200637-1
SuSE Security Announcement: SUSE-SA:2007:067 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2007-12/msg00005.html
http://www.ubuntu.com/usn/usn-609-1
BugTraq ID: 26703
http://www.securityfocus.com/bid/26703
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10153
http://www.vupen.com/english/advisories/2007/4092
http://www.vupen.com/english/advisories/2007/4146
http://www.securitytracker.com/id?1019041
http://secunia.com/advisories/27914
http://secunia.com/advisories/27916
http://secunia.com/advisories/27928
http://secunia.com/advisories/27931
http://secunia.com/advisories/27972
http://secunia.com/advisories/28018
http://secunia.com/advisories/28039
http://secunia.com/advisories/28286
http://secunia.com/advisories/28585
http://secunia.com/advisories/30100
XForce ISS Database: openoffice-hsqldb-code-execution(38882)
http://xforce.iss.net/xforce/xfdb/38882
Common Vulnerability Exposure (CVE) ID: CVE-2007-5745
http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=691
https://bugzilla.redhat.com/show_bug.cgi?id=435678
Debian Security Information: DSA-1547 (Google Search)
http://www.debian.org/security/2008/dsa-1547
https://www.redhat.com/archives/fedora-package-announce/2008-April/msg00448.html
http://security.gentoo.org/glsa/glsa-200805-16.xml
http://www.redhat.com/support/errata/RHSA-2008-0175.html
http://sunsolve.sun.com/search/document.do?assetkey=1-26-231601-1
SuSE Security Announcement: SUSE-SA:2008:023 (Google Search)
http://www.novell.com/linux/security/advisories/2008_23_openoffice.html
BugTraq ID: 28819
http://www.securityfocus.com/bid/28819
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11006
http://www.vupen.com/english/advisories/2008/1253/references
http://www.vupen.com/english/advisories/2008/1375/references
http://www.securitytracker.com/id?1019891
http://secunia.com/advisories/29864
http://secunia.com/advisories/29913
http://secunia.com/advisories/29852
http://secunia.com/advisories/29910
http://secunia.com/advisories/29871
http://secunia.com/advisories/29987
http://secunia.com/advisories/30179
XForce ISS Database: openoffice-quattropro-bo(41863)
http://xforce.iss.net/xforce/xfdb/41863
Common Vulnerability Exposure (CVE) ID: CVE-2007-5746
http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=692
http://www.mandriva.com/security/advisories?name=MDVSA-2008:090
http://www.redhat.com/support/errata/RHSA-2008-0176.html
http://sunsolve.sun.com/search/document.do?assetkey=1-66-231661-1
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10249
http://www.securitytracker.com/id?1019892
http://secunia.com/advisories/29844
XForce ISS Database: openoffice-emf-bo(41861)
http://xforce.iss.net/xforce/xfdb/41861
Common Vulnerability Exposure (CVE) ID: CVE-2007-5747
http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=693
https://bugzilla.redhat.com/show_bug.cgi?id=435681
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11298
XForce ISS Database: openoffice-quattropro-code-execution(41881)
http://xforce.iss.net/xforce/xfdb/41881
Common Vulnerability Exposure (CVE) ID: CVE-2008-0320
http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=694
http://sunsolve.sun.com/search/document.do?assetkey=1-26-231642-1
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10318
http://www.securitytracker.com/id?1019890
XForce ISS Database: openoffice-ole-bo(41860)
http://xforce.iss.net/xforce/xfdb/41860
CopyrightCopyright (c) 2008 E-Soft Inc. http://www.securityspace.com

This is only one of 39212 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.