Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.60145
Category:Ubuntu Local Security Checks
Title:Ubuntu USN-565-1 (squid)
Summary:NOSUMMARY
Description:Description:

The remote host is missing an update to squid
announced via advisory USN-565-1.

A security issue affects the following Ubuntu releases:

Ubuntu 6.06 LTS
Ubuntu 6.10
Ubuntu 7.04
Ubuntu 7.10

This advisory also applies to the corresponding versions of
Kubuntu, Edubuntu, and Xubuntu.

It was discovered that Squid did not always clean up cache memory
correctly. A remote attacker could manipulate cache update replies and
cause Squid to use all available memory, leading to a denial of service.

Solution:
The problem can be corrected by upgrading your system to the
following package versions:

Ubuntu 6.06 LTS:
squid 2.5.12-4ubuntu2.3

Ubuntu 6.10:
squid 2.6.1-3ubuntu1.5

Ubuntu 7.04:
squid 2.6.5-4ubuntu2.1

Ubuntu 7.10:
squid 2.6.14-1ubuntu2.1

In general, a standard system upgrade is sufficient to effect the
necessary changes.

http://www.securityspace.com/smysecure/catid.html?in=USN-565-1

Risk factor : Medium

CVSS Score:
5.0

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2007-6239
BugTraq ID: 26687
http://www.securityfocus.com/bid/26687
CERT/CC vulnerability note: VU#232881
http://www.kb.cert.org/vuls/id/232881
Debian Security Information: DSA-1482 (Google Search)
http://www.debian.org/security/2008/dsa-1482
https://www.redhat.com/archives/fedora-package-announce/2007-December/msg00507.html
https://www.redhat.com/archives/fedora-package-announce/2007-December/msg00497.html
http://security.gentoo.org/glsa/glsa-200801-05.xml
http://security.gentoo.org/glsa/glsa-200903-38.xml
http://www.mandriva.com/security/advisories?name=MDVSA-2008:002
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10915
http://www.redhat.com/support/errata/RHSA-2007-1130.html
http://www.securitytracker.com/id?1019036
http://secunia.com/advisories/27910
http://secunia.com/advisories/28091
http://secunia.com/advisories/28109
http://secunia.com/advisories/28350
http://secunia.com/advisories/28381
http://secunia.com/advisories/28403
http://secunia.com/advisories/28412
http://secunia.com/advisories/28814
http://secunia.com/advisories/34467
SuSE Security Announcement: SUSE-SR:2008:001 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2008-01/msg00002.html
http://www.ubuntu.com/usn/usn-565-1
http://www.vupen.com/english/advisories/2007/4066
CopyrightCopyright (c) 2008 E-Soft Inc. http://www.securityspace.com

This is only one of 99761 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2022 E-Soft Inc. All rights reserved.