English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 76783 CVE descriptions
and 40246 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.59229
Category:Ubuntu Local Security Checks
Title:Ubuntu USN-539-1 (cupsys)
Summary:Ubuntu USN-539-1 (cupsys)
Description:
The remote host is missing an update to cupsys
announced via advisory USN-539-1.

A security issue affects the following Ubuntu releases:

Ubuntu 6.06 LTS
Ubuntu 6.10
Ubuntu 7.04
Ubuntu 7.10

This advisory also applies to the corresponding versions of
Kubuntu, Edubuntu, and Xubuntu.

Details follow:

Alin Rad Pop discovered that CUPS did not correctly validate buffer
lengths when processing IPP tags. Remote attackers successfully
exploiting this vulnerability would gain access to the non-root CUPS user
in Ubuntu 6.06 LTS, 6.10, and 7.04. In Ubuntu 7.10, attackers would be
isolated by the AppArmor CUPS profile.

Solution:
The problem can be corrected by upgrading your system to the
following package versions:

Ubuntu 6.06 LTS:
cupsys 1.2.2-0ubuntu0.6.06.4

Ubuntu 6.10:
cupsys 1.2.4-2ubuntu3.1

Ubuntu 7.04:
cupsys 1.2.8-0ubuntu8.1

Ubuntu 7.10:
cupsys 1.3.2-1ubuntu7.1

In general, a standard system upgrade is sufficient to affect the
necessary changes.

http://www.securityspace.com/smysecure/catid.html?in=USN-539-1

Risk factor : Critical
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2007-4351
http://secunia.com/secunia_research/2007-76/advisory/
http://lists.apple.com/archives/security-announce/2007/Dec/msg00002.html
Cisco Security Advisory: 20080625 Wide Area Application Services (WAAS) Common UNIX Printing System (CUPS) Vulnerability
http://www.cisco.com/en/US/products/products_security_response09186a00809a1f11.html
Debian Security Information: DSA-1407 (Google Search)
http://www.debian.org/security/2007/dsa-1407
https://www.redhat.com/archives/fedora-package-announce/2007-November/msg00012.html
http://security.gentoo.org/glsa/glsa-200711-16.xml
http://www.mandriva.com/security/advisories?name=MDKSA-2007:204
http://www.redhat.com/support/errata/RHSA-2007-1020.html
http://www.redhat.com/support/errata/RHSA-2007-1022.html
http://www.redhat.com/support/errata/RHSA-2007-1023.html
http://slackware.com/security/viewer.php?l=slackware-security&y=2007&m=slackware-security.501902
SuSE Security Announcement: SUSE-SA:2007:058 (Google Search)
http://www.novell.com/linux/security/advisories/2007_58_cups.html
http://www.ubuntulinux.org/support/documentation/usn/usn-539-1
Cert/CC Advisory: TA07-352A
http://www.us-cert.gov/cas/techalerts/TA07-352A.html
CERT/CC vulnerability note: VU#446897
http://www.kb.cert.org/vuls/id/446897
BugTraq ID: 26268
http://www.securityfocus.com/bid/26268
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10604
http://www.vupen.com/english/advisories/2007/3681
http://www.vupen.com/english/advisories/2007/4238
http://www.vupen.com/english/advisories/2008/1934/references
http://www.securitytracker.com/id?1018879
http://secunia.com/advisories/27233
http://secunia.com/advisories/27410
http://secunia.com/advisories/27445
http://secunia.com/advisories/27474
http://secunia.com/advisories/27447
http://secunia.com/advisories/27494
http://secunia.com/advisories/27499
http://secunia.com/advisories/27540
http://secunia.com/advisories/27577
http://secunia.com/advisories/27604
http://secunia.com/advisories/27712
http://secunia.com/advisories/28136
http://secunia.com/advisories/30847
XForce ISS Database: cups-ippreadio-bo(38190)
http://xforce.iss.net/xforce/xfdb/38190
CopyrightCopyright (c) 2007 E-Soft Inc. http://www.securityspace.com

This is only one of 40246 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.