English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 72022 CVE descriptions
and 38680 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.58699
Category:Gentoo Local Security Checks
Title:Gentoo Security Advisory GLSA 200710-20 (pdfkit imagekits)
Summary:Gentoo Security Advisory GLSA 200710-20 (pdfkit imagekits)
Description:The remote host is missing updates announced in
advisory GLSA 200710-20.

PDFKit and ImageKits are vulnerable to an integer overflow and a stack
overflow allowing for the user-assisted execution of arbitrary code.

Solution:
PDFKit and ImageKits are not maintained upstream, so the packages were
masked in Portage. We recommend that users unmerge PDFKit and ImageKits:

# emerge --unmerge gnustep-libs/pdfkit
# emerge --unmerge gnustep-libs/imagekits

As an alternative, users should upgrade their systems to use PopplerKit
instead of PDFKit and Vindaloo instead of ViewPDF.

http://www.securityspace.com/smysecure/catid.html?in=GLSA%20200710-20
http://bugs.gentoo.org/show_bug.cgi?id=188185
http://www.gentoo.org/security/en/glsa/glsa-200709-12.xml
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2007-3387
Bugtraq: 20070814 FLEA-2007-0044-1 tetex tetex-dvips tetex-fonts (Google Search)
http://www.securityfocus.com/archive/1/archive/1/476508/100/0/threaded
Bugtraq: 20070814 FLEA-2007-0045-1 poppler (Google Search)
http://www.securityfocus.com/archive/1/archive/1/476519/30/5400/threaded
Bugtraq: 20070816 FLEA-2007-0046-1 cups (Google Search)
http://www.securityfocus.com/archive/1/archive/1/476765/30/5340/threaded
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=248194
http://bugs.gentoo.org/show_bug.cgi?id=187139
Debian Security Information: DSA-1347 (Google Search)
http://www.debian.org/security/2007/dsa-1347
Debian Security Information: DSA-1348 (Google Search)
http://www.debian.org/security/2007/dsa-1348
Debian Security Information: DSA-1349 (Google Search)
http://www.debian.org/security/2007/dsa-1349
Debian Security Information: DSA-1350 (Google Search)
http://www.debian.org/security/2007/dsa-1350
Debian Security Information: DSA-1352 (Google Search)
http://www.debian.org/security/2007/dsa-1352
Debian Security Information: DSA-1355 (Google Search)
http://www.debian.org/security/2007/dsa-1355
Debian Security Information: DSA-1354 (Google Search)
http://www.debian.org/security/2007/dsa-1354
Debian Security Information: DSA-1357 (Google Search)
http://www.debian.org/security/2007/dsa-1357
http://security.gentoo.org/glsa/glsa-200709-12.xml
http://www.gentoo.org/security/en/glsa/glsa-200710-08.xml
http://security.gentoo.org/glsa/glsa-200710-20.xml
http://security.gentoo.org/glsa/glsa-200709-17.xml
http://security.gentoo.org/glsa/glsa-200711-34.xml
http://security.gentoo.org/glsa/glsa-200805-13.xml
http://www.mandriva.com/security/advisories?name=MDKSA-2007:162
http://www.mandriva.com/security/advisories?name=MDKSA-2007:158
http://www.mandriva.com/security/advisories?name=MDKSA-2007:159
http://www.mandriva.com/security/advisories?name=MDKSA-2007:160
http://www.mandriva.com/security/advisories?name=MDKSA-2007:161
http://www.mandriva.com/security/advisories?name=MDKSA-2007:163
http://www.mandriva.com/security/advisories?name=MDKSA-2007:164
http://www.mandriva.com/security/advisories?name=MDKSA-2007:165
http://www.redhat.com/support/errata/RHSA-2007-0730.html
http://www.redhat.com/support/errata/RHSA-2007-0720.html
http://www.redhat.com/support/errata/RHSA-2007-0729.html
http://www.redhat.com/support/errata/RHSA-2007-0732.html
http://www.redhat.com/support/errata/RHSA-2007-0735.html
http://www.redhat.com/support/errata/RHSA-2007-0731.html
SGI Security Advisory: 20070801-01-P
ftp://patches.sgi.com/support/free/security/advisories/20070801-01-P.asc
http://www.slackware.org/security/viewer.php?l=slackware-security&y=2007&m=slackware-security.423670
http://slackware.com/security/viewer.php?l=slackware-security&y=2007&m=slackware-security.761882
SuSE Security Announcement: SUSE-SR:2007:015 (Google Search)
http://www.novell.com/linux/security/advisories/2007_15_sr.html
SuSE Security Announcement: SUSE-SR:2007:016 (Google Search)
http://www.novell.com/linux/security/advisories/2007_16_sr.html
http://www.ubuntu.com/usn/usn-496-1
http://www.ubuntu.com/usn/usn-496-2
BugTraq ID: 25124
http://www.securityfocus.com/bid/25124
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11149
http://www.vupen.com/english/advisories/2007/2704
http://www.vupen.com/english/advisories/2007/2705
http://osvdb.org/40127
http://www.securitytracker.com/id?1018473
http://secunia.com/advisories/26188
http://secunia.com/advisories/26254
http://secunia.com/advisories/26255
http://secunia.com/advisories/26257
http://secunia.com/advisories/26278
http://secunia.com/advisories/26281
http://secunia.com/advisories/26283
http://secunia.com/advisories/26251
http://secunia.com/advisories/26293
http://secunia.com/advisories/26292
http://secunia.com/advisories/26307
http://secunia.com/advisories/26318
http://secunia.com/advisories/26342
http://secunia.com/advisories/26297
http://secunia.com/advisories/26343
http://secunia.com/advisories/26358
http://secunia.com/advisories/26325
http://secunia.com/advisories/26365
http://secunia.com/advisories/26370
http://secunia.com/advisories/26413
http://secunia.com/advisories/26410
http://secunia.com/advisories/26403
http://secunia.com/advisories/26405
http://secunia.com/advisories/26407
http://secunia.com/advisories/26432
http://secunia.com/advisories/26436
http://secunia.com/advisories/26467
http://secunia.com/advisories/26468
http://secunia.com/advisories/26470
http://secunia.com/advisories/26425
http://secunia.com/advisories/26395
http://secunia.com/advisories/26514
http://secunia.com/advisories/26607
http://secunia.com/advisories/26862
http://secunia.com/advisories/27156
http://secunia.com/advisories/27281
http://secunia.com/advisories/27308
http://secunia.com/advisories/27637
http://secunia.com/advisories/26627
http://secunia.com/advisories/26982
http://secunia.com/advisories/30168
CopyrightCopyright (c) 2007 E-Soft Inc. http://www.securityspace.com

This is only one of 38680 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.