English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 73247 CVE descriptions
and 39212 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.57052
Category:Ubuntu Local Security Checks
Title:Ubuntu USN-300-1 (wv2)
Summary:Ubuntu USN-300-1 (wv2)
Description:
The remote host is missing an update to wv2
announced via advisory USN-300-1.

A security issue affects the following Ubuntu releases:

Ubuntu 5.04
Ubuntu 5.10
Ubuntu 6.06 LTS

This advisory also applies to the corresponding versions of
Kubuntu, Edubuntu, and Xubuntu.

libwv2 did not sufficiently check the validity of its input. Certain
invalid Word documents caused a buffer overflow. By tricking a user
into opening a specially crafted Word file with an application that
uses libwv2, this could be exploited to execute arbitrary code with
the user's privileges.

The only packaged application using this library is KWord.

Solution:
The problem can be corrected by upgrading your system to the
following package versions:

Ubuntu 5.04:
libwv2-1 0.2.2-1ubuntu1.1
libwv2-dev 0.2.2-1ubuntu1.1

Ubuntu 5.10:
libwv2-1c2 0.2.2-1ubuntu2.1
libwv2-dev 0.2.2-1ubuntu2.1

Ubuntu 6.06 LTS:
libwv2-1c2 0.2.2-5ubuntu0.1
libwv2-dev 0.2.2-5ubuntu0.1

After a standard system upgrade you need to restart KWord to effect
the necessary changes.

http://www.securityspace.com/smysecure/catid.html?in=USN-300-1

Risk factor : High
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2006-2197
Debian Security Information: DSA-1100 (Google Search)
http://www.debian.org/security/2006/dsa-1100
http://www.gentoo.org/security/en/glsa/glsa-200606-24.xml
http://www.mandriva.com/security/advisories?name=MDKSA-2006:109
SuSE Security Announcement: SUSE-SR:2006:015 (Google Search)
http://www.novell.com/linux/security/advisories/2006_38_security.html
http://www.ubuntulinux.org/support/documentation/usn/usn-300-1
BugTraq ID: 18437
http://www.securityfocus.com/bid/18437
http://www.vupen.com/english/advisories/2006/2350
http://securitytracker.com/id?1016313
http://secunia.com/advisories/20665
http://secunia.com/advisories/20688
http://secunia.com/advisories/20689
http://secunia.com/advisories/20826
http://secunia.com/advisories/20844
http://secunia.com/advisories/20899
XForce ISS Database: wvware-wv2-word-overflow(27184)
http://xforce.iss.net/xforce/xfdb/27184
CopyrightCopyright (c) 2006 E-Soft Inc. http://www.securityspace.com

This is only one of 39212 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.