English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 73247 CVE descriptions
and 39337 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.57042
Category:Ubuntu Local Security Checks
Title:Ubuntu USN-292-1 (binutils)
Summary:Ubuntu USN-292-1 (binutils)
Description:
The remote host is missing an update to binutils
announced via advisory USN-292-1.

A security issue affects the following Ubuntu releases:

Ubuntu 5.04
Ubuntu 5.10
Ubuntu 6.06 LTS

This advisory also applies to the corresponding versions of
Kubuntu, Edubuntu, and Xubuntu.

CVE-2006-2362
Jesus Olmos Gonzalez discovered a buffer overflow in the Tektronix Hex
Format (TekHex) backend of the BFD library, such as used by the
'strings' utility. By tricking an user or automated system into
processing a specially crafted file with 'strings' or a vulnerable
third-party application using the BFD library, this could be exploited
to crash the application, or possibly even execute arbitrary code with
the privileges of the user.

Solution:
The problem can be corrected by upgrading your system to the
following package versions:

Ubuntu 5.04:
binutils 2.15-5ubuntu2.3
binutils-dev 2.15-5ubuntu2.3

Ubuntu 5.10:
binutils 2.16.1-2ubuntu6.1
binutils-dev 2.16.1-2ubuntu6.1

Ubuntu 6.06 LTS:
binutils 2.16.1cvs20060117-1ubuntu2.1
binutils-dev 2.16.1cvs20060117-1ubuntu2.1

In general, a standard system upgrade is sufficient to effect the
necessary changes.
http://www.securityspace.com/smysecure/catid.html?in=USN-292-1

Risk factor : High
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2006-2362
http://www.mail-archive.com/bug-binutils@gnu.org/msg01516.html
http://lists.apple.com/archives/security-announce/2007/Oct/msg00001.html
SuSE Security Announcement: SUSE-SR:2006:026 (Google Search)
http://www.novell.com/linux/security/advisories/2006_26_sr.html
http://www.trustix.org/errata/2006/0034/
http://www.ubuntu.com/usn/usn-292-1
BugTraq ID: 17950
http://www.securityfocus.com/bid/17950
http://www.vupen.com/english/advisories/2006/1924
http://www.vupen.com/english/advisories/2007/3665
http://www.securitytracker.com/id?1018872
http://secunia.com/advisories/20188
http://secunia.com/advisories/20531
http://secunia.com/advisories/22932
http://secunia.com/advisories/20550
http://secunia.com/advisories/27441
XForce ISS Database: binutils-libbfd-bo(26644)
http://xforce.iss.net/xforce/xfdb/26644
CopyrightCopyright (c) 2006 E-Soft Inc. http://www.securityspace.com

This is only one of 39337 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.