English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 75803 CVE descriptions
and 40037 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.55021
Category:Ubuntu Local Security Checks
Title:Ubuntu USN-163-1 (xpdf)
Summary:Ubuntu USN-163-1 (xpdf)
Description:
The remote host is missing an update to xpdf
announced via advisory USN-163-1.

A security issue affects the following Ubuntu releases:

Ubuntu 4.10 (Warty Warthog)
Ubuntu 5.04 (Hoary Hedgehog)

The following packages are affected:

xpdf-reader
xpdf-utils
kpdf

xpdf and kpdf did not sufficiently verify the validity of the loca
table in PDF files, a table that contains glyph description
information for embedded TrueType fonts. After detecting the broken
table, xpdf attempted to reconstruct the information in it, which
caused the generation of a huge temporary file that quickly filled up
available disk space and rendered the application unresponsive.

The CUPS printing system in Ubuntu 5.04 uses the xpdf-utils package to
convert PDF files to PostScript. By attempting to print such a crafted
PDF file, a remote attacker could cause a Denial of Service in a print
server. The CUPS system in Ubuntu 4.10 is not vulnerable against this
attack.

Solution:
The problem can be corrected by upgrading the affected package to
version 3.00-8ubuntu1.5 (for Ubuntu 4.10), or 3.00-11ubuntu3.1
(xpdf-reader and xpdf-utils for Ubuntu 5.04) and 4:3.4.0-0ubuntu3.1
(kpdf for Ubuntu 5.04). In general, a standard system upgrade is
sufficient to effect the necessary changes.

http://www.securityspace.com/smysecure/catid.html?in=USN-163-1

Risk factor : Medium
Cross-Ref: BugTraq ID: 14529
Common Vulnerability Exposure (CVE) ID: CVE-2005-2097
Debian Security Information: DSA-780 (Google Search)
http://www.debian.org/security/2005/dsa-780
Debian Security Information: DSA-936 (Google Search)
http://www.debian.org/security/2006/dsa-936
Debian Security Information: DSA-1136 (Google Search)
http://www.debian.org/security/2006/dsa-1136
http://www.securityfocus.com/archive/1/archive/1/427990/100/0/threaded
http://www.securityfocus.com/archive/1/archive/1/427053/100/0/threaded
http://www.mandriva.com/security/advisories?name=MDKSA-2005:138
http://www.redhat.com/support/errata/RHSA-2005-670.html
http://www.redhat.com/support/errata/RHSA-2005-671.html
http://www.redhat.com/support/errata/RHSA-2005-706.html
http://www.redhat.com/support/errata/RHSA-2005-708.html
SCO Security Bulletin: SCOSA-2005.42
ftp://ftp.sco.com/pub/updates/OpenServer/SCOSA-2005.42/SCOSA-2005.42.txt
http://sunsolve.sun.com/search/document.do?assetkey=1-26-102972-1
SuSE Security Announcement: SUSE-SR:2005:019 (Google Search)
http://www.novell.com/linux/security/advisories/2005_19_sr.html
http://www.ubuntulinux.org/support/documentation/usn/usn-163-1
http://www.securityfocus.com/bid/14529
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10280
http://www.vupen.com/english/advisories/2007/2280
http://secunia.com/advisories/17277
http://secunia.com/advisories/18398
http://secunia.com/advisories/18407
http://secunia.com/advisories/21339
http://secunia.com/advisories/25729
CopyrightCopyright (c) 2005 E-Soft Inc. http://www.securityspace.com

This is only one of 40037 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.