English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 76783 CVE descriptions
and 40246 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.51364
Category:Conectiva Local Security Checks
Title:Conectiva Security Advisory CLA-2004:868
Summary:Conectiva Security Advisory CLA-2004:868
Description:
The remote host is missing updates announced in
advisory CLA-2004:868.

Apache[1] is the most popular webserver in use today.

This announcement fixes the following issues with apache, mod_ssl and
mod_dav:

1. Denial of service in ap_get_mime_headers_core() function
(CVE-2004-0493[2])

The ap_get_mime_headers_core() function in Apache httpd 2.0.49 allows
remote attackers to cause a denial of service (memory exhaustion).

2. Buffer overflow in .htaccess files handler (CVE-2004-0747[3])

Buffer overflow in Apache 2.0.50 and earlier allows local attackers
to gain apache privileges via a .htaccess file that causes the buffer
overflow during expansion of environment variables.

3. Denial of service in mod_ssl (CVE-2004-0748[4])

mod_ssl in Apache 2.0.50 and earlier allows remote attackers to cause
a denial of service (CPU consumption) by aborting an SSL connection
in a way that causes an Apache child process to enter an infinite
loop.

4. Denial of service in char_buffer_read() function in mod_ssl
(CVE-2004-0751[5])

The char_buffer_read function in the mod_ssl module for Apache 2.x,
when using reverse proxying to an SSL server, allows remote attackers
to cause a denial of service (segmentation fault).

5. Denial of service in IPv6 URI parsing routines (CVE-2004-0786[6])

The IPv6 URI parsing routines in the apr-util library for Apache
2.0.50 and earlier allow remote attackers to cause a denial of
service (child process crash) via a certain URI, as demonstrated
using the Codenomicon HTTP Test Tool.

6. Denial of service in mod_dav (CVE-2004-0809[7])

The mod_dav module in Apache 2.0.50 and earlier allows remote
attackers to cause a denial of service (child process crash) via a
certain sequence of LOCK requests for a location that allows WebDAV
authoring access.


Solution:
The apt tool can be used to perform RPM package upgrades
by running 'apt-get update' followed by 'apt-get upgrade'

http://apache.httpd.org/
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0493
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0747
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0748
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0751
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0786
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0809
http://www.securityspace.com/smysecure/catid.html?in=CLA-2004:868
http://distro.conectiva.com.br/atualizacoes/index.php?id=a&anuncio=002004

Risk factor : High
Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2004-0493
http://lists.grok.org.uk/pipermail/full-disclosure/2004-June/023133.html
http://www.guninski.com/httpd1.html
Bugtraq: 20040629 TSSA-2004-012 - apache (Google Search)
http://marc.theaimsgroup.com/?l=bugtraq&m=108853066800184&w=2
http://security.gentoo.org/glsa/glsa-200407-03.xml
HPdes Security Advisory: SSRT4777
http://marc.theaimsgroup.com/?l=bugtraq&m=109181600614477&w=2
http://www.mandriva.com/security/advisories?name=MDKSA-2004:064
http://www.redhat.com/support/errata/RHSA-2004-342.html
http://www.trustix.org/errata/2004/0039/
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10605
XForce ISS Database: apache-apgetmimeheaderscore-dos(16524)
http://xforce.iss.net/xforce/xfdb/16524
BugTraq ID: 10619
http://www.securityfocus.com/bid/10619
Common Vulnerability Exposure (CVE) ID: CVE-2004-0747
http://support.ca.com/irj/portal/anonymous/phpsupcontent?contentID=205147
http://www.gentoo.org/security/en/glsa/glsa-200409-21.xml
http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2004:096
http://www.redhat.com/support/errata/RHSA-2004-463.html
SuSE Security Announcement: SUSE-SA:2004:032 (Google Search)
http://www.novell.com/linux/security/advisories/2004_32_apache2.html
http://www.trustix.org/errata/2004/0047/
CERT/CC vulnerability note: VU#481998
http://www.kb.cert.org/vuls/id/481998
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11561
http://securitytracker.com/id?1011303
http://secunia.com/advisories/12540
http://secunia.com/advisories/34920
http://www.vupen.com/english/advisories/2009/1233
XForce ISS Database: apache-env-configuration-bo(17384)
http://xforce.iss.net/xforce/xfdb/17384
Common Vulnerability Exposure (CVE) ID: CVE-2004-0748
http://www.redhat.com/support/errata/RHSA-2004-349.html
SuSE Security Announcement: SUSE-SA:2004:030 (Google Search)
http://www.novell.com/linux/security/advisories/2004_30_apache2.html
AUSCERT Advisory: ESB-2004.0553
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11126
XForce ISS Database: apache-modssl-dos(17200)
http://xforce.iss.net/xforce/xfdb/17200
Common Vulnerability Exposure (CVE) ID: CVE-2004-0751
Bugtraq: 20040911 Remote buffer overflow in Apache mod_ssl when reverse proxying SSL (Google Search)
http://archives.neohapsis.com/archives/bugtraq/2004-09/0096.html
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11864
XForce ISS Database: apache-modssl-speculative-dos(17273)
http://xforce.iss.net/xforce/xfdb/17273
Common Vulnerability Exposure (CVE) ID: CVE-2004-0786
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11380
XForce ISS Database: apache-ipv6-aprutil-dos(17382)
http://xforce.iss.net/xforce/xfdb/17382
Common Vulnerability Exposure (CVE) ID: CVE-2004-0809
Debian Security Information: DSA-558 (Google Search)
http://www.debian.org/security/2004/dsa-558
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:9588
XForce ISS Database: apache-moddav-lock-dos(17366)
http://xforce.iss.net/xforce/xfdb/17366
CopyrightCopyright (c) 2005 E-Soft Inc. http://www.securityspace.com

This is only one of 40246 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2014 E-Soft Inc. All rights reserved.