Vulnerability   
Search   
    Search 191973 CVE descriptions
and 86218 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.144709
Category:Databases
Title:PostgreSQL < 9.5.23, 9.6.x < 9.6.19, 10.x < 10.14, 11.x < 11.9, 12.x < 12.4 Search Path Vulnerability (Linux)
Summary:PostgreSQL is prone to an uncontrolled search path element vulnerability in; CREATE EXTENSION.
Description:Summary:
PostgreSQL is prone to an uncontrolled search path element vulnerability in
CREATE EXTENSION.

Vulnerability Impact:
When a superuser runs certain CREATE EXTENSION statements, users may be able to
execute arbitrary SQL functions under the identity of that superuser. The attacker must have permission to
create objects in the new extension's schema or a schema of a prerequisite extension. Not all extensions are
vulnerable.

Affected Software/OS:
PostgreSQL versions prior to 9.5.23, 9.6.x prior to 9.6.19, 10.x prior to
10.14, 11.x prior to 11.9 and 12.x prior to 12.4.

Solution:
Update to version 9.5.23, 9.6.19, 10.14, 11.9, 12.4 or later.

CVSS Score:
4.4

CVSS Vector:
AV:L/AC:M/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-14350
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 86218 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.