Vulnerability   
Search   
    Search 191973 CVE descriptions
and 86218 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.144704
Category:General
Title:PowerDNS Authoritative Server Multiple Vulnerabilities (2020-06)
Summary:PowerDNS Authoritative Server is prone to multiple vulnerabilities in the; GSS-TSIG support.
Description:Summary:
PowerDNS Authoritative Server is prone to multiple vulnerabilities in the
GSS-TSIG support.

Vulnerability Insight:
The following vulnerabilities exist:

- A remote, unauthenticated attacker can trigger a race condition leading to a crash, or possibly arbitrary code
execution, by sending crafted queries with a GSS-TSIG signature (CVE-2020-24696)

- A remote, unauthenticated attacker can cause a denial of service by sending crafted queries with a GSS-TSIG
signature (CVE-2020-24697)

- A remote, unauthenticated attacker might be able to cause a double-free, leading to a crash or possibly
arbitrary code execution by sending crafted queries with a GSS-TSIG signature (CVE-2020-24698)

Affected Software/OS:
PowerDNS Authoritative prior to version 4.4.0.

Solution:
Update to version 4.4.0 or later.

CVSS Score:
6.8

CVSS Vector:
AV:N/AC:M/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-24696
Common Vulnerability Exposure (CVE) ID: CVE-2020-24697
Common Vulnerability Exposure (CVE) ID: CVE-2020-24698
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 86218 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.