Vulnerability   
Search   
    Search 187964 CVE descriptions
and 85075 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.144458
Category:Denial of Service
Title:Squid Proxy Cache Security Update Advisory SQUID-2020:9
Summary:Squid is prone to a denial of service vulnerability when processing Cache; Digest responses.
Description:Summary:
Squid is prone to a denial of service vulnerability when processing Cache
Digest responses.

Vulnerability Insight:
Due to Improper Input Validation Squid is vulnerable to a denial of service
attack against the machine operating Squid.

Vulnerability Impact:
This problem allows a trusted peer to perform a Denial of Service by
consuming all available CPU cycles on the machine running Squid when handling a crafted Cache Digest response
message.

This attack is limited to Squid using cache_peer with cache digests feature.

Affected Software/OS:
Squid versions 3.0 - 4.12 and 5.0.1 - 5.0.3.

Solution:
Update to version 4.13, 5.0.4 or later.

CVSS Score:
7.1

CVSS Vector:
AV:N/AC:M/Au:N/C:N/I:N/A:C

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-24606
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 85075 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.