Vulnerability   
Search   
    Search 191973 CVE descriptions
and 86218 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.117033
Category:General
Title:OpenSSL < 0.9.6 Security Bypass Vulnerability
Summary:OpenSSL is prone to a security bypass vulnerability.
Description:Summary:
OpenSSL is prone to a security bypass vulnerability.

Vulnerability Insight:
crypto/rsa/rsa_gen.c in OpenSSL mishandles C bitwise-shift operations
that exceed the size of an expression.

Vulnerability Impact:
The flaw makes it easier for remote attackers to defeat cryptographic
protection mechanisms by leveraging improper RSA key generation.

Affected Software/OS:
OpenSSL versions prior to 0.9.6 on 64-bit HP-UX platforms.

Solution:
Update to version 0.9.6 or later.

CVSS Score:
5.0

CVSS Vector:
AV:N/AC:L/Au:N/C:P/I:N/A:N

Cross-Ref: BugTraq ID: 90109
Common Vulnerability Exposure (CVE) ID: CVE-2000-1254
http://www.securityfocus.com/bid/90109
http://marc.info/?l=openssl-users&m=95961024500509
http://www.openwall.com/lists/oss-security/2016/05/04/17
http://www.securitytracker.com/id/1035750
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 86218 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.