Vulnerability   
Search   
    Search 191973 CVE descriptions
and 86218 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.117009
Category:Web Servers
Title:nginx 1.5.10 'ngx_http_spdy_module' RCE Vulnerability
Summary:nginx is prone to a remote code execution vulnerability in the; ngx_http_spdy_module module.
Description:Summary:
nginx is prone to a remote code execution vulnerability in the
ngx_http_spdy_module module.

Vulnerability Insight:
A bug in the experimental SPDY implementation in nginx was found,
which might allow an attacker to corrupt worker process memory by using a specially crafted request,
potentially resulting in arbitrary code execution.

Affected Software/OS:
The problem only affects nginx 1.5.10 on 32-bit platforms, compiled with
the ngx_http_spdy_module module (which is not compiled by default), if the 'spdy' option of the 'listen'
directive is used in a configuration file.

Solution:
Update to version 1.5.11 or later.

CVSS Score:
7.5

CVSS Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2014-0088
http://mailman.nginx.org/pipermail/nginx-announce/2014/000132.html
http://www.securitytracker.com/id/1030150
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 86218 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.