English | Deutsch | Español | Português
 ID de Usuario:
 Contraseña:
Nuevo usuario
 Acerca de:   Dedicada | Avanzada | Estándar | Periódica | Sin Riesgo | Escritorio | Básica | Individual | Sello | FAQ
  Resumen de Precio/Funciones | Ordenar  | Nuevas Vulnerabilidades | Confidencialidad | Búsqueda de Vulnerabilidad
 Búsqueda de    
Vulnerabilidad   
    Buscar 75803 Descripciones CVE y
40037 Descripciones de Pruebas,
accesos 10,000+ referencias cruzadas.
Pruebas   CVE   Todos  

ID de Prueba:1.3.6.1.4.1.25623.1.0.61290
Categoría:Red Hat Local Security Checks
Título:RedHat Security Advisory RHSA-2008:0546
Resumen:Redhat Security Advisory RHSA-2008:0546
Descripción:
The remote host is missing updates announced in
advisory RHSA-2008:0546.

PHP is an HTML-embedded scripting language commonly used with the Apache
HTTP Web server.

It was discovered that the PHP escapeshellcmd() function did not properly
escape multi-byte characters which are not valid in the locale used by the
script. This could allow an attacker to bypass quoting restrictions imposed
by escapeshellcmd() and execute arbitrary commands if the PHP script was
using certain locales. Scripts using the default UTF-8 locale are not
affected by this issue. (CVE-2008-2051)

The PHP functions htmlentities() and htmlspecialchars() did not properly
recognize partial multi-byte sequences. Certain sequences of bytes could be
passed through these functions without being correctly HTML-escaped.
Depending on the browser being used, an attacker could use this flaw to
conduct cross-site scripting attacks. (CVE-2007-5898)

A PHP script which used the transparent session ID configuration option, or
which used the output_add_rewrite_var() function, could leak session
identifiers to external web sites. If a page included an HTML form with an
ACTION attribute referencing a non-local URL, the user's session ID would
be included in the form data passed to that URL. (CVE-2007-5899)

It was discovered that PHP did not properly seed its pseudo-random number
generator used by functions such as rand() and mt_rand(), possibly allowing
an attacker to easily predict the generated pseudo-random values.
(CVE-2008-2107, CVE-2008-2108)

Integer overflow and memory requirements miscalculation issues were
discovered in the Perl-Compatible Regular Expression (PCRE) library used by
PHP to process regular expressions. These issues could cause a crash, or
possibly execute an arbitrary code with the privileges of the PHP script
that processes regular expressions from untrusted sources. Note: PHP
packages shipped with Red Hat Enterprise Linux 2.1 did not use the
system-level PCRE library. By default they used an embedded copy of the
library included with the PHP package. (CVE-2006-7228, CVE-2007-1660)

Users of PHP should upgrade to these updated packages, which contain
backported patches to correct these issues.

Solution:
Please note that this update is available via
Red Hat Network. To use Red Hat Network, launch the Red
Hat Update Agent with the following command: up2date

http://rhn.redhat.com/errata/RHSA-2008-0546.html
http://www.redhat.com/security/updates/classification/#moderate

Risk factor : Critical
Referencia Cruzada: Common Vulnerability Exposure (CVE) ID: CVE-2008-2051
Bugtraq: 20080523 rPSA-2008-0176-1 php php-cgi php-imap php-mcrypt php-mysql php-mysqli php-pgsql php-soap php-xsl php5 php5-cgi php5-imap php5-mcrypt php5-mysql php5-mysqli php5-pear php5-pgsql php5-soap php5-xsl (Google Search)
http://www.securityfocus.com/archive/1/archive/1/492535/100/0/threaded
Bugtraq: 20080527 rPSA-2008-0178-1 php php-mysql php-pgsql (Google Search)
http://www.securityfocus.com/archive/1/archive/1/492671/100/0/threaded
http://www.openwall.com/lists/oss-security/2008/05/02/2
http://lists.apple.com/archives/security-announce//2008/Jul/msg00003.html
Debian Security Information: DSA-1578 (Google Search)
http://www.debian.org/security/2008/dsa-1578
Debian Security Information: DSA-1572 (Google Search)
http://www.debian.org/security/2008/dsa-1572
https://www.redhat.com/archives/fedora-package-announce/2008-June/msg00779.html
https://www.redhat.com/archives/fedora-package-announce/2008-June/msg00773.html
http://security.gentoo.org/glsa/glsa-200811-05.xml
http://www.mandriva.com/security/advisories?name=MDVSA-2008:125
http://www.mandriva.com/security/advisories?name=MDVSA-2008:126
http://www.mandriva.com/security/advisories?name=MDVSA-2008:127
http://www.mandriva.com/security/advisories?name=MDVSA-2008:128
http://www.redhat.com/support/errata/RHSA-2008-0505.html
http://www.redhat.com/support/errata/RHSA-2008-0544.html
http://www.redhat.com/support/errata/RHSA-2008-0545.html
http://www.redhat.com/support/errata/RHSA-2008-0546.html
http://www.redhat.com/support/errata/RHSA-2008-0582.html
http://marc.info/?l=slackware-security&m=121022465827871&w=2
SuSE Security Announcement: SUSE-SR:2008:014 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2008-07/msg00001.html
http://www.ubuntu.com/usn/usn-628-1
BugTraq ID: 29009
http://www.securityfocus.com/bid/29009
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10256
http://secunia.com/advisories/32746
http://www.vupen.com/english/advisories/2008/1412
http://www.vupen.com/english/advisories/2008/2268
http://secunia.com/advisories/30048
http://secunia.com/advisories/30288
http://secunia.com/advisories/30345
http://secunia.com/advisories/30411
http://secunia.com/advisories/30757
http://secunia.com/advisories/30828
http://secunia.com/advisories/30967
http://secunia.com/advisories/31119
http://secunia.com/advisories/31124
http://secunia.com/advisories/31200
http://secunia.com/advisories/31326
http://secunia.com/advisories/30083
http://secunia.com/advisories/30158
Common Vulnerability Exposure (CVE) ID: CVE-2007-5898
Debian Security Information: DSA-1444 (Google Search)
http://www.debian.org/security/2008/dsa-1444
HPdes Security Advisory: HPSBUX02332
http://www.securityfocus.com/archive/1/archive/1/491693/100/0/threaded
HPdes Security Advisory: SSRT080056
SuSE Security Announcement: SUSE-SA:2008:004 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2008-01/msg00006.html
http://www.ubuntulinux.org/support/documentation/usn/usn-549-1
http://www.ubuntu.com/usn/usn-549-2
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10080
http://securitytracker.com/id?1018934
http://secunia.com/advisories/27648
http://secunia.com/advisories/27659
http://secunia.com/advisories/27864
http://secunia.com/advisories/28249
http://secunia.com/advisories/28658
http://secunia.com/advisories/30040
Common Vulnerability Exposure (CVE) ID: CVE-2007-5899
http://osvdb.org/38918
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11211
Common Vulnerability Exposure (CVE) ID: CVE-2006-7228
Bugtraq: 20080221 VMSA-2008-0003 Moderate: Updated aacraid driver and samba and python service console updates (Google Search)
http://www.securityfocus.com/archive/1/archive/1/488457/100/0/threaded
Bugtraq: 20080416 VMSA-2008-0007 Moderate Updated Service Console packages pcre, net-snmp, and OpenPegasus (Google Search)
http://www.securityfocus.com/archive/1/archive/1/490917/100/0/threaded
http://lists.vmware.com/pipermail/security-announce/2008/000005.html
http://lists.vmware.com/pipermail/security-announce/2008/000014.html
http://scary.beasts.org/security/CESA-2007-006.html
https://bugzilla.redhat.com/show_bug.cgi?id=383371
http://bugs.gentoo.org/show_bug.cgi?id=198976
Debian Security Information: DSA-1570 (Google Search)
http://www.debian.org/security/2008/dsa-1570
http://security.gentoo.org/glsa/glsa-200711-30.xml
http://security.gentoo.org/glsa/glsa-200801-02.xml
http://security.gentoo.org/glsa/glsa-200801-18.xml
http://security.gentoo.org/glsa/glsa-200801-19.xml
http://security.gentoo.org/glsa/glsa-200802-10.xml
http://security.gentoo.org/glsa/glsa-200805-11.xml
http://www.mandriva.com/security/advisories?name=MDVSA-2008:012
http://www.mandriva.com/security/advisories?name=MDVSA-2008:030
http://www.redhat.com/support/errata/RHSA-2007-1063.html
http://www.redhat.com/support/errata/RHSA-2007-1065.html
http://www.redhat.com/support/errata/RHSA-2007-1059.html
http://www.redhat.com/support/errata/RHSA-2007-1068.html
http://www.redhat.com/support/errata/RHSA-2007-1076.html
http://www.redhat.com/support/errata/RHSA-2007-1077.html
SuSE Security Announcement: SUSE-SA:2007:062 (Google Search)
http://www.novell.com/linux/security/advisories/2007_62_pcre.html
BugTraq ID: 26462
http://www.securityfocus.com/bid/26462
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10810
http://www.vupen.com/english/advisories/2008/0637
http://www.vupen.com/english/advisories/2008/1234/references
http://secunia.com/advisories/27582
http://secunia.com/advisories/27741
http://secunia.com/advisories/27773
http://secunia.com/advisories/27776
http://secunia.com/advisories/28027
http://secunia.com/advisories/28050
http://secunia.com/advisories/28041
http://secunia.com/advisories/28406
http://secunia.com/advisories/28414
http://secunia.com/advisories/28714
http://secunia.com/advisories/28720
http://secunia.com/advisories/29032
http://secunia.com/advisories/29085
http://secunia.com/advisories/29785
http://secunia.com/advisories/30155
http://secunia.com/advisories/30219
http://secunia.com/advisories/30106
Common Vulnerability Exposure (CVE) ID: CVE-2007-1660
Bugtraq: 20071106 rPSA-2007-0231-1 pcre (Google Search)
http://www.securityfocus.com/archive/1/archive/1/483357/100/0/threaded
Bugtraq: 20071112 FLEA-2007-0064-1 pcre (Google Search)
http://www.securityfocus.com/archive/1/archive/1/483579/100/0/threaded
http://mail.gnome.org/archives/gtk-devel-list/2007-November/msg00022.html
http://lists.apple.com/archives/security-announce/2007/Dec/msg00002.html
http://lists.apple.com/archives/security-announce/2008/Mar/msg00001.html
Debian Security Information: DSA-1399 (Google Search)
http://www.debian.org/security/2007/dsa-1399
http://www.mandriva.com/security/advisories?name=MDKSA-2007:211
http://www.mandriva.com/security/advisories?name=MDKSA-2007:212
http://www.mandriva.com/security/advisories?name=MDKSA-2007:213
http://www.redhat.com/support/errata/RHSA-2007-0967.html
http://www.redhat.com/support/errata/RHSA-2007-0968.html
SuSE Security Announcement: SUSE-SR:2007:025 (Google Search)
http://www.novell.com/linux/security/advisories/2007_25_sr.html
http://www.ubuntulinux.org/support/documentation/usn/usn-547-1
Cert/CC Advisory: TA07-352A
http://www.us-cert.gov/cas/techalerts/TA07-352A.html
BugTraq ID: 26346
http://www.securityfocus.com/bid/26346
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10562
http://www.vupen.com/english/advisories/2007/3725
http://www.vupen.com/english/advisories/2007/3790
http://www.vupen.com/english/advisories/2007/4238
http://www.vupen.com/english/advisories/2008/0924/references
http://securitytracker.com/id?1018895
http://secunia.com/advisories/27598
http://secunia.com/advisories/27538
http://secunia.com/advisories/27543
http://secunia.com/advisories/27547
http://secunia.com/advisories/27554
http://secunia.com/advisories/27697
http://secunia.com/advisories/27862
http://secunia.com/advisories/27965
http://secunia.com/advisories/28136
http://secunia.com/advisories/29420
XForce ISS Database: pcre-character-class-dos(38273)
http://xforce.iss.net/xforce/xfdb/38273
Common Vulnerability Exposure (CVE) ID: CVE-2008-2107
Bugtraq: 20080506 Advisory SE-2008-02: PHP GENERATE_SEED() Weak Random Number Seed Vulnerability (Google Search)
http://www.securityfocus.com/archive/1/archive/1/491683/100/0/threaded
http://archives.neohapsis.com/archives/fulldisclosure/2008-05/0103.html
http://www.sektioneins.de/advisories/SE-2008-02.txt
Debian Security Information: DSA-1789 (Google Search)
http://www.debian.org/security/2009/dsa-1789
http://www.mandriva.com/security/advisories?name=MDVSA-2008:129
http://www.mandriva.com/security/advisories?name=MDVSA-2008:130
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10644
http://secunia.com/advisories/35003
http://securityreason.com/securityalert/3859
XForce ISS Database: php-generateseed-weak-security(42226)
http://xforce.iss.net/xforce/xfdb/42226
XForce ISS Database: php-generateseed-security-bypass(42284)
http://xforce.iss.net/xforce/xfdb/42284
Common Vulnerability Exposure (CVE) ID: CVE-2008-2108
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10844
CopyrightCopyright (c) 2008 E-Soft Inc. http://www.securityspace.com

Esta es sólo una de 40037 pruebas de vulnerabilidad en nuestra serie de pruebas. Encuentre más sobre cómo ejecutar una auditoría de seguridad completa.

Para ejecutar una prueba gratuita de esta vulnerabilidad contra su sistema, regístrese ahora.

Registro de Nuevo Usuario
Email:
Usuario:
Contraseña:
Envíeme por email sus boletines mensuales, informándome los últimos servicios, mejoras y encuestas.
Por favor envíeme por email un anuncio de prueba de vulnerabilidades siempre que se agregue una nueva prueba.
   Privacidad
Ingreso de Usuario Registrado
 
Usuario:   
Contraseña:  

 ¿Olvidó su usuario o contraseña??
Email/ID de Usario:




Principal | Acerca de Nosotros | Contáctenos | Programas de Asociado | Developer APIs | Privacidad | Listas de Correo | Abuso
Auditorías de Seguridad | DNS Administrado | Monitoreo de Red | Analizador de Sitio | Informes de Investigación de Internet
Prueba de Web | Whois

© 1998-2014 E-Soft Inc. Todos los derechos reservados.