Vulnerability   
Search   
    Search 191973 CVE descriptions
and 86218 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.1.2.2020.2172
Category:Huawei EulerOS Local Security Checks
Title:Huawei EulerOS: Security Advisory for trousers (EulerOS-SA-2020-2172)
Summary:The remote host is missing an update for the Huawei EulerOS; 'trousers' package(s) announced via the EulerOS-SA-2020-2172 advisory.
Description:Summary:
The remote host is missing an update for the Huawei EulerOS
'trousers' package(s) announced via the EulerOS-SA-2020-2172 advisory.

Vulnerability Insight:
An issue was discovered in TrouSerS through 0.3.14. If the tcsd daemon is started with root privileges instead of by the tss user, it fails to drop the root gid privilege when no longer needed.(CVE-2020-24330)

An issue was discovered in TrouSerS through 0.3.14. If the tcsd daemon is started with root privileges, the tss user still has read and write access to the /etc/tcsd.conf file (which contains various settings related to this daemon).(CVE-2020-24331)

An issue was discovered in TrouSerS through 0.3.14. If the tcsd daemon is started with root privileges, the creation of the system.data file is prone to symlink attacks. The tss user can be used to create or corrupt existing files, which could possibly lead to a DoS attack.(CVE-2020-24332)

Affected Software/OS:
'trousers' package(s) on Huawei EulerOS V2.0SP9.

Solution:
Please install the updated package(s).

CVSS Score:
7.2

CVSS Vector:
AV:L/AC:L/Au:N/C:C/I:C/A:C

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-24330
Common Vulnerability Exposure (CVE) ID: CVE-2020-24331
Common Vulnerability Exposure (CVE) ID: CVE-2020-24332
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 86218 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.