Vulnerability   
Search   
    Search 187964 CVE descriptions
and 85075 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.892375
Category:Debian Local Security Checks
Title:Debian LTS: Security Advisory for inspircd (DLA-2375-1)
Summary:The remote host is missing an update for the 'inspircd'; package(s) announced via the DLA-2375-1 advisory.
Description:Summary:
The remote host is missing an update for the 'inspircd'
package(s) announced via the DLA-2375-1 advisory.

Vulnerability Insight:
Two security issues were discovered in the modules of the InspIRCd IRC
daemon, which could result in denial of service.

CVE-2019-20917

mysql module before v3.3.0 contains a null pointer dereference when
built against mariadb-connector-c. When combined with the sqlauth or
sqloper modules this vulnerability can be used to remotely crash an
InspIRCd server by any user able to connect to a server.

CVE-2020-25269

The pgsql module contains a use after free vulnerability. When combined
with the sqlauth or sqloper modules this vulnerability can be used to
remotely crash an InspIRCd server by any user able to connect to a
server.

Affected Software/OS:
'inspircd' package(s) on Debian Linux.

Solution:
For Debian 9 stretch, these problems have been fixed in version
2.0.23-2+deb9u1.

We recommend that you upgrade your inspircd packages.

CVSS Score:
6.8

CVSS Vector:
AV:N/AC:L/Au:S/C:N/I:N/A:C

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2019-20917
Common Vulnerability Exposure (CVE) ID: CVE-2020-25269
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 85075 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.