Vulnerability   
Search   
    Search 187964 CVE descriptions
and 85075 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.892365
Category:Debian Local Security Checks
Title:Debian LTS: Security Advisory for netty-3.9 (DLA-2365-1)
Summary:The remote host is missing an update for the 'netty-3.9'; package(s) announced via the DLA-2365-1 advisory.
Description:Summary:
The remote host is missing an update for the 'netty-3.9'
package(s) announced via the DLA-2365-1 advisory.

Vulnerability Insight:
Several vulnerabilities have been discovered in netty-3.9, a Java NIO
client/server socket framework.

CVE-2019-16869

Netty before 4.1.42.Final mishandles whitespace before the colon in
HTTP headers (such as a 'Transfer-Encoding : chunked' line), which
leads to HTTP request smuggling.

CVE-2019-20444

HttpObjectDecoder.java in Netty before 4.1.44 allows an HTTP header
that lacks a colon, which might be interpreted as a separate header
with an incorrect syntax, or might be interpreted as an 'invalid
fold.'

CVE-2019-20445

HttpObjectDecoder.java in Netty before 4.1.44 allows a Content-Length
header to be accompanied by a second Content-Length header, or by a
Transfer-Encoding header.

Affected Software/OS:
'netty-3.9' package(s) on Debian Linux.

Solution:
For Debian 9 stretch, these problems have been fixed in version
3.9.9.Final-1+deb9u1.

We recommend that you upgrade your netty-3.9 packages.

CVSS Score:
6.4

CVSS Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:N

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2019-16869
Common Vulnerability Exposure (CVE) ID: CVE-2019-20444
Common Vulnerability Exposure (CVE) ID: CVE-2019-20445
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 85075 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.