English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 143769 CVE descriptions
and 71225 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.891619
Category:Debian Local Security Checks
Title:Debian LTS Advisory ([SECURITY] [DLA 1619-1] graphicsmagick security update)
Summary:Multiple vulnerabilities have been found in GraphicsMagick, the image;processing system.;;CVE-2018-20184;;The WriteTGAImage function (tga.c) is affected by a heap-based buffer;overflow. Remote attackers might leverage this vulnerability to cause;a denial of service via a crafted image file.;;CVE-2018-20185;;The ReadBMPImage function (bmp.c) is affected by a heap-based buffer;over-read. Remote attackers might leverage this vulnerability to cause;a denial of service via a crafted image file.;;CVE-2018-20189;;The ReadDIBImage function (coders/dib.c) is affected by an assertion;error. Remote attackers might leverage this vulnerability to cause;a denial of service via a crafted image file.
Description:Summary:
Multiple vulnerabilities have been found in GraphicsMagick, the image
processing system.

CVE-2018-20184

The WriteTGAImage function (tga.c) is affected by a heap-based buffer
overflow. Remote attackers might leverage this vulnerability to cause
a denial of service via a crafted image file.

CVE-2018-20185

The ReadBMPImage function (bmp.c) is affected by a heap-based buffer
over-read. Remote attackers might leverage this vulnerability to cause
a denial of service via a crafted image file.

CVE-2018-20189

The ReadDIBImage function (coders/dib.c) is affected by an assertion
error. Remote attackers might leverage this vulnerability to cause
a denial of service via a crafted image file.

Vulnerability Insight:
GraphicsMagick provides a set of command-line applications to manipulate
image files. It is a fork of the ImageMagick project and therefore offers
a similar set of features, but puts a larger emphasis on stability.

Affected Software/OS:
graphicsmagick on Debian Linux

Solution:
For Debian 8 'Jessie', these problems have been fixed in version
1.3.20-3+deb8u5.

We recommend that you upgrade your graphicsmagick packages.

CVSS Score:
5.0

CVSS Vector:
AV:N/AC:L/Au:N/C:P/I:N/A:N

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2018-20184
Common Vulnerability Exposure (CVE) ID: CVE-2018-20185
Common Vulnerability Exposure (CVE) ID: CVE-2018-20189
CopyrightCopyright (c) 2018 Greenbone Networks GmbH http://greenbone.net

This is only one of 71225 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe

© 1998-2019 E-Soft Inc. All rights reserved.