English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 134041 CVE descriptions
and 69903 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.891395
Category:Debian Local Security Checks
Title:Debian LTS Advisory ([SECURITY] [DLA 1395-1] php-horde-image security update)
Summary:It was discovered that there were two remote code execution;vulnerabilities in php-horde-image, the image processing library for the;Horde https://www.horde.org/ groupware tool:;; * CVE-2017-9774: A remote code execution vulnerability (RCE) that was; exploitable by a logged-in user sending a maliciously crafted HTTP GET; request to various image backends.; ; Note that the fix applied upstream has a regression in that it ignores; the 'force aspect ratio' option. See https://github.com/horde/Image/pull/1.;; * CVE-2017-14650: Another RCE that was exploitable by a logged-in; user sending a maliciously crafted GET request specifically to the 'im'; image backend.
Description:Summary:
It was discovered that there were two remote code execution
vulnerabilities in php-horde-image, the image processing library for the
Horde https://www.horde.org/ groupware tool:

* CVE-2017-9774: A remote code execution vulnerability (RCE) that was
exploitable by a logged-in user sending a maliciously crafted HTTP GET
request to various image backends.

Note that the fix applied upstream has a regression in that it ignores
the 'force aspect ratio' option. See https://github.com/horde/Image/pull/1.

* CVE-2017-14650: Another RCE that was exploitable by a logged-in
user sending a maliciously crafted GET request specifically to the 'im'
image backend.

Vulnerability Insight:
An Image utility API, with backends for:
* GD
* GIF
* PNG
* SVG
* SWF
* ImageMagick convert command line tool
* Imagick Extension

Affected Software/OS:
php-horde-image on Debian Linux

Solution:
For Debian 8 'Jessie', these issues have been fixed in php-horde-image
version 2.1.0-4+deb8u1.

We recommend that you upgrade your php-horde-image packages.

CVSS Score:
6.8

CVSS Vector:
AV:N/AC:M/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2017-9774
Debian Security Information: DSA-4276 (Google Search)
https://www.debian.org/security/2018/dsa-4276
CopyrightCopyright (c) 2018 Greenbone Networks GmbH http://greenbone.net

This is only one of 69903 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe

© 1998-2018 E-Soft Inc. All rights reserved.