Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.878725
Category:Fedora Local Security Checks
Title:Fedora: Security Advisory for php-wikimedia-assert (FEDORA-2020-a4802c53d9)
Summary:The remote host is missing an update for the 'php-wikimedia-assert'; package(s) announced via the FEDORA-2020-a4802c53d9 advisory.
Description:Summary:
The remote host is missing an update for the 'php-wikimedia-assert'
package(s) announced via the FEDORA-2020-a4802c53d9 advisory.

Vulnerability Insight:
This package provides an alternative to PHP', s assert() that allows for a
simple and reliable way to check preconditions and postconditions in PHP
code. It was proposed as a MediaWiki RFC, but is completely generic and
can be used by any PHP program or library.

Affected Software/OS:
'php-wikimedia-assert' package(s) on Fedora 33.

Solution:
Please install the updated package(s).

CVSS Score:
5.0

CVSS Vector:
AV:N/AC:L/Au:N/C:N/I:P/A:N

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-26120
Common Vulnerability Exposure (CVE) ID: CVE-2020-26121
Common Vulnerability Exposure (CVE) ID: CVE-2020-25815
Common Vulnerability Exposure (CVE) ID: CVE-2020-25827
Common Vulnerability Exposure (CVE) ID: CVE-2020-25813
Common Vulnerability Exposure (CVE) ID: CVE-2020-25812
Common Vulnerability Exposure (CVE) ID: CVE-2020-25869
Common Vulnerability Exposure (CVE) ID: CVE-2020-25814
Common Vulnerability Exposure (CVE) ID: CVE-2020-25828
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 99761 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.