Vulnerability   
Search   
    Search 187964 CVE descriptions
and 85075 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.878170
Category:Fedora Local Security Checks
Title:Fedora: Security Advisory for python2 (FEDORA-2020-826b24c329)
Summary:The remote host is missing an update for the 'python2'; package(s) announced via the FEDORA-2020-826b24c329 advisory.
Description:Summary:
The remote host is missing an update for the 'python2'
package(s) announced via the FEDORA-2020-826b24c329 advisory.

Vulnerability Insight:
Python 2 is an old version of the language that is incompatible with the 3.x
line of releases. The language is mostly the same, but many details, especially
how built-in objects like dictionaries and strings work, have changed
considerably, and a lot of deprecated features have finally been removed in the
3.x line.

Note that documentation for Python 2 is provided in the python2-docs
package.

This package provides the 'python2' executable, most of the actual
implementation is within the 'python2-libs' package.

Affected Software/OS:
'python2' package(s) on Fedora 31.

Solution:
Please install the updated package(s).

CVSS Score:
5.0

CVSS Vector:
AV:N/AC:L/Au:N/C:N/I:N/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2019-20907
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 85075 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.