Vulnerability   
Search   
    Search 211766 CVE descriptions
and 97459 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.871845
Category:Red Hat Local Security Checks
Title:RedHat Update for java-1.8.0-openjdk RHSA-2017:1789-01
Summary:The remote host is missing an update for the 'java-1.8.0-openjdk'; package(s) announced via the referenced advisory.
Description:Summary:
The remote host is missing an update for the 'java-1.8.0-openjdk'
package(s) announced via the referenced advisory.

Vulnerability Insight:
The java-1.8.0-openjdk packages provide
the OpenJDK 8 Java Runtime Environment and the OpenJDK 8 Java Software Development
Kit.

Security Fix(es):

* It was discovered that the DCG implementation in the RMI component of
OpenJDK failed to correctly handle references. A remote attacker could
possibly use this flaw to execute arbitrary code with the privileges of RMI
registry or a Java RMI application. (CVE-2017-10102)

* Multiple flaws were discovered in the RMI, JAXP, ImageIO, Libraries, AWT,
Hotspot, and Security components in OpenJDK. An untrusted Java application
or applet could use these flaws to completely bypass Java sandbox
restrictions. (CVE-2017-10107, CVE-2017-10096, CVE-2017-10101,
CVE-2017-10089, CVE-2017-10090, CVE-2017-10087, CVE-2017-10111,
CVE-2017-10110, CVE-2017-10074, CVE-2017-10067)

* It was discovered that the LDAPCertStore class in the Security component
of OpenJDK followed LDAP referrals to arbitrary URLs. A specially crafted
LDAP referral URL could cause LDAPCertStore to communicate with non-LDAP
servers. (CVE-2017-10116)

* It was discovered that the Nashorn JavaScript engine in the Scripting
component of OpenJDK could allow scripts to access Java APIs even when
access to Java APIs was disabled. An untrusted JavaScript executed by
Nashorn could use this flaw to bypass intended restrictions.
(CVE-2017-10078)

* It was discovered that the Security component of OpenJDK could fail to
properly enforce restrictions defined for processing of X.509 certificate
chains. A remote attacker could possibly use this flaw to make Java accept
certificate using one of the disabled algorithms. (CVE-2017-10198)

* A covert timing channel flaw was found in the DSA implementation in the
JCE component of OpenJDK. A remote attacker able to make a Java application
generate DSA signatures on demand could possibly use this flaw to extract
certain information about the used key via a timing side channel.
(CVE-2017-10115)

* A covert timing channel flaw was found in the PKCS#8 implementation in
the JCE component of OpenJDK. A remote attacker able to make a Java
application repeatedly compare PKCS#8 key against an attacker controlled
value could possibly use this flaw to determine the key via a timing side
channel. (CVE-2017-10135)

* It was discovered that the BasicAttribute and CodeSource classes in
OpenJDK did not limit the amount of memory allocated when creating object
instances from a serialized form. A specially crafted seri ...

Description truncated, please see the referenced URL(s) for more information.

Affected Software/OS:
java-1.8.0-openjdk on
Red Hat Enterprise Linux Desktop (v. 6),
Red Hat Enterprise Linux Server (v. 6),
Red Hat Enterprise Linux Server (v. 7),
Red Hat Enterprise Linux Workstation (v. 6)

Solution:
Please Install the Updated Packages.

CVSS Score:
6.8

CVSS Vector:
AV:N/AC:M/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2017-10053
Common Vulnerability Exposure (CVE) ID: CVE-2017-10067
Common Vulnerability Exposure (CVE) ID: CVE-2017-10074
Common Vulnerability Exposure (CVE) ID: CVE-2017-10078
Common Vulnerability Exposure (CVE) ID: CVE-2017-10081
Common Vulnerability Exposure (CVE) ID: CVE-2017-10087
Common Vulnerability Exposure (CVE) ID: CVE-2017-10089
Common Vulnerability Exposure (CVE) ID: CVE-2017-10090
Common Vulnerability Exposure (CVE) ID: CVE-2017-10096
Common Vulnerability Exposure (CVE) ID: CVE-2017-10101
Common Vulnerability Exposure (CVE) ID: CVE-2017-10102
Common Vulnerability Exposure (CVE) ID: CVE-2017-10107
Common Vulnerability Exposure (CVE) ID: CVE-2017-10108
Common Vulnerability Exposure (CVE) ID: CVE-2017-10109
Common Vulnerability Exposure (CVE) ID: CVE-2017-10110
Common Vulnerability Exposure (CVE) ID: CVE-2017-10111
Common Vulnerability Exposure (CVE) ID: CVE-2017-10115
Common Vulnerability Exposure (CVE) ID: CVE-2017-10116
Common Vulnerability Exposure (CVE) ID: CVE-2017-10135
Common Vulnerability Exposure (CVE) ID: CVE-2017-10193
Common Vulnerability Exposure (CVE) ID: CVE-2017-10198
CopyrightCopyright (C) 2017 Greenbone Networks GmbH

This is only one of 97459 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.