Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.871282
Category:Red Hat Local Security Checks
Title:RedHat Update for wget RHSA-2014:1764-01
Summary:The remote host is missing an update for the 'wget'; package(s) announced via the referenced advisory.
Description:Summary:
The remote host is missing an update for the 'wget'
package(s) announced via the referenced advisory.

Vulnerability Insight:
The wget package provides the GNU Wget file retrieval utility for HTTP,
HTTPS, and FTP protocols.

A flaw was found in the way Wget handled symbolic links. A malicious FTP
server could allow Wget running in the mirror mode (using the '-m' command
line option) to write an arbitrary file to a location writable to by the
user running Wget, possibly leading to code execution. (CVE-2014-4877)

Note: This update changes the default value of the --retr-symlinks option.
The file symbolic links are now traversed by default and pointed-to files
are retrieved rather than creating a symbolic link locally.

Red Hat would like to thank the GNU Wget project for reporting this issue.
Upstream acknowledges HD Moore of Rapid7, Inc as the original reporter.

All users of wget are advised to upgrade to this updated package, which
contains a backported patch to correct this issue.

Affected Software/OS:
wget on Red Hat Enterprise Linux Desktop (v. 6),
Red Hat Enterprise Linux Server (v. 6),
Red Hat Enterprise Linux Server (v. 7),
Red Hat Enterprise Linux Workstation (v. 6)

Solution:
Please Install the Updated Packages.

CVSS Score:
9.3

CVSS Vector:
AV:N/AC:M/Au:N/C:C/I:C/A:C

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2014-4877
BugTraq ID: 70751
http://www.securityfocus.com/bid/70751
CERT/CC vulnerability note: VU#685996
http://www.kb.cert.org/vuls/id/685996
Debian Security Information: DSA-3062 (Google Search)
http://www.debian.org/security/2014/dsa-3062
http://security.gentoo.org/glsa/glsa-201411-05.xml
http://www.mandriva.com/security/advisories?name=MDVSA-2015:121
https://community.rapid7.com/community/metasploit/blog/2014/10/28/r7-2014-15-gnu-wget-ftp-symlink-arbitrary-filesystem-access
https://github.com/rapid7/metasploit-framework/pull/4088
http://lists.gnu.org/archive/html/bug-wget/2014-10/msg00150.html
RedHat Security Advisories: RHSA-2014:1764
http://rhn.redhat.com/errata/RHSA-2014-1764.html
RedHat Security Advisories: RHSA-2014:1955
http://rhn.redhat.com/errata/RHSA-2014-1955.html
SuSE Security Announcement: SUSE-SU-2014:1366 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2014-11/msg00004.html
SuSE Security Announcement: SUSE-SU-2014:1408 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2014-11/msg00009.html
SuSE Security Announcement: openSUSE-SU-2014:1380 (Google Search)
http://lists.opensuse.org/opensuse-updates/2014-11/msg00026.html
http://www.ubuntu.com/usn/USN-2393-1
CopyrightCopyright (C) 2014 Greenbone Networks GmbH

This is only one of 99761 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.