Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.871281
Category:Red Hat Local Security Checks
Title:RedHat Update for php RHSA-2014:1767-01
Summary:The remote host is missing an update for the 'php'; package(s) announced via the referenced advisory.
Description:Summary:
The remote host is missing an update for the 'php'
package(s) announced via the referenced advisory.

Vulnerability Insight:
PHP is an HTML-embedded scripting language commonly used with the Apache
HTTP Server.

A buffer overflow flaw was found in the Exif extension. A specially crafted
JPEG or TIFF file could cause a PHP application using the exif_thumbnail()
function to crash or, possibly, execute arbitrary code with the privileges
of the user running that PHP application. (CVE-2014-3670)

An integer overflow flaw was found in the way custom objects were
unserialized. Specially crafted input processed by the unserialize()
function could cause a PHP application to crash. (CVE-2014-3669)

An out-of-bounds read flaw was found in the way the File Information
(fileinfo) extension parsed Executable and Linkable Format (ELF) files.
A remote attacker could use this flaw to crash a PHP application using
fileinfo via a specially crafted ELF file. (CVE-2014-3710)

An out of bounds read flaw was found in the way the xmlrpc extension parsed
dates in the ISO 8601 format. A specially crafted XML-RPC request or
response could possibly cause a PHP application to crash. (CVE-2014-3668)

The CVE-2014-3710 issue was discovered by Francisco Alonso of Red Hat
Product Security.

All php users are advised to upgrade to these updated packages, which
contain backported patches to correct these issues. After installing the
updated packages, the httpd daemon must be restarted for the update to
take effect.

Affected Software/OS:
php on Red Hat Enterprise Linux Server (v. 6),
Red Hat Enterprise Linux Server (v. 7),
Red Hat Enterprise Linux Workstation (v. 6)

Solution:
Please Install the Updated Packages.

CVSS Score:
7.5

CVSS Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2014-3668
http://lists.apple.com/archives/security-announce/2015/Apr/msg00001.html
BugTraq ID: 70666
http://www.securityfocus.com/bid/70666
Debian Security Information: DSA-3064 (Google Search)
http://www.debian.org/security/2014/dsa-3064
RedHat Security Advisories: RHSA-2014:1765
http://rhn.redhat.com/errata/RHSA-2014-1765.html
RedHat Security Advisories: RHSA-2014:1766
http://rhn.redhat.com/errata/RHSA-2014-1766.html
RedHat Security Advisories: RHSA-2014:1767
http://rhn.redhat.com/errata/RHSA-2014-1767.html
RedHat Security Advisories: RHSA-2014:1768
http://rhn.redhat.com/errata/RHSA-2014-1768.html
http://secunia.com/advisories/59967
http://secunia.com/advisories/60630
http://secunia.com/advisories/60699
http://secunia.com/advisories/61763
http://secunia.com/advisories/61970
http://secunia.com/advisories/61982
SuSE Security Announcement: openSUSE-SU-2014:1377 (Google Search)
http://lists.opensuse.org/opensuse-updates/2014-11/msg00024.html
SuSE Security Announcement: openSUSE-SU-2014:1391 (Google Search)
http://lists.opensuse.org/opensuse-updates/2014-11/msg00034.html
SuSE Security Announcement: openSUSE-SU-2015:0014 (Google Search)
http://lists.opensuse.org/opensuse-updates/2015-01/msg00006.html
http://www.ubuntu.com/usn/USN-2391-1
Common Vulnerability Exposure (CVE) ID: CVE-2014-3669
BugTraq ID: 70611
http://www.securityfocus.com/bid/70611
RedHat Security Advisories: RHSA-2014:1824
http://rhn.redhat.com/errata/RHSA-2014-1824.html
Common Vulnerability Exposure (CVE) ID: CVE-2014-3670
BugTraq ID: 70665
http://www.securityfocus.com/bid/70665
Common Vulnerability Exposure (CVE) ID: CVE-2014-3710
BugTraq ID: 70807
http://www.securityfocus.com/bid/70807
Debian Security Information: DSA-3072 (Google Search)
http://www.debian.org/security/2014/dsa-3072
FreeBSD Security Advisory: FreeBSD-SA-14:28
https://www.freebsd.org/security/advisories/FreeBSD-SA-14:28.file.asc
https://security.gentoo.org/glsa/201503-03
https://security.gentoo.org/glsa/201701-42
RedHat Security Advisories: RHSA-2016:0760
http://rhn.redhat.com/errata/RHSA-2016-0760.html
http://www.securitytracker.com/id/1031344
http://secunia.com/advisories/62347
http://secunia.com/advisories/62559
SuSE Security Announcement: openSUSE-SU-2014:1516 (Google Search)
http://lists.opensuse.org/opensuse-updates/2014-11/msg00113.html
http://www.ubuntu.com/usn/USN-2494-1
CopyrightCopyright (C) 2014 Greenbone Networks GmbH

This is only one of 99761 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.