Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.871122
Category:Red Hat Local Security Checks
Title:RedHat Update for wget RHSA-2014:0151-01
Summary:The remote host is missing an update for the 'wget'; package(s) announced via the referenced advisory.
Description:Summary:
The remote host is missing an update for the 'wget'
package(s) announced via the referenced advisory.

Vulnerability Insight:
The wget package provides the GNU Wget file retrieval utility for HTTP,
HTTPS, and FTP protocols. Wget provides various useful features, such as
the ability to work in the background while the user is logged out,
recursive retrieval of directories, file name wildcard matching or updating
files in dependency on file timestamp comparison.

It was discovered that wget used a file name provided by the server when
saving a downloaded file. This could cause wget to create a file with a
different name than expected, possibly allowing the server to execute
arbitrary code on the client. (CVE-2010-2252)

Note: With this update, wget always uses the last component of the original
URL as the name for the downloaded file. Previous behavior of using the
server provided name or the last component of the redirected URL when
creating files can be re-enabled by using the '--trust-server-names'
command line option, or by setting 'trust_server_names=on' in the wget
start-up file.

This update also fixes the following bugs:

* Prior to this update, the wget package did not recognize HTTPS SSL
certificates with alternative names (subjectAltName) specified in the
certificate as valid. As a consequence, running the wget command failed
with a certificate error. This update fixes wget to recognize such
certificates as valid. (BZ#1060113)

All users of wget are advised to upgrade to this updated package, which
contain backported patches to correct these issues.

Affected Software/OS:
wget on Red Hat Enterprise Linux Desktop (v. 6),
Red Hat Enterprise Linux Server (v. 6),
Red Hat Enterprise Linux Workstation (v. 6)

Solution:
Please Install the Updated Packages.

CVSS Score:
6.8

CVSS Vector:
AV:N/AC:M/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2010-2252
BugTraq ID: 65722
http://www.securityfocus.com/bid/65722
http://www.ocert.org/advisories/ocert-2010-001.html
http://lists.gnu.org/archive/html/bug-wget/2010-05/msg00031.html
http://lists.gnu.org/archive/html/bug-wget/2010-05/msg00033.html
http://lists.gnu.org/archive/html/bug-wget/2010-05/msg00023.html
http://lists.gnu.org/archive/html/bug-wget/2010-05/msg00032.html
http://lists.gnu.org/archive/html/bug-wget/2010-05/msg00034.html
http://marc.info/?l=oss-security&m=127412569216380&w=2
http://marc.info/?l=oss-security&m=127411372529485&w=2
http://marc.info/?l=oss-security&m=127416905831994&w=2
http://marc.info/?l=oss-security&m=127422615924593&w=2
http://marc.info/?l=oss-security&m=127427572721591&w=2
http://marc.info/?l=oss-security&m=127432968701342&w=2
http://marc.info/?l=oss-security&m=127441275821210&w=2
http://marc.info/?l=oss-security&m=127611288927500&w=2
RedHat Security Advisories: RHSA-2014:0151
http://rhn.redhat.com/errata/RHSA-2014-0151.html
CopyrightCopyright (C) 2014 Greenbone Networks GmbH

This is only one of 99761 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.