Vulnerability   
Search   
    Search 191973 CVE descriptions
and 86218 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.853507
Category:SuSE Local Security Checks
Title:openSUSE: Security Advisory for gcc10, (openSUSE-SU-2020:1693-1)
Summary:The remote host is missing an update for the 'gcc10, '; package(s) announced via the openSUSE-SU-2020:1693-1 advisory.
Description:Summary:
The remote host is missing an update for the 'gcc10, '
package(s) announced via the openSUSE-SU-2020:1693-1 advisory.

Vulnerability Insight:
This update for gcc10, nvptx-tools fixes the following issues:

This update provides the GCC10 compiler suite and runtime libraries.

The base SUSE Linux Enterprise libraries libgcc_s1, libstdc++6 are
replaced by the gcc10 variants.

The new compiler variants are available with '-10' suffix, you can specify
them via:

CC=gcc-10 CXX=g++-10

or similar commands.

Changes in nvptx-tools:

- Enable build on aarch64

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.2:

zypper in -t patch openSUSE-2020-1693=1

Affected Software/OS:
'gcc10, ' package(s) on openSUSE Leap 15.2.

Solution:
Please install the updated package(s).

CVSS Score:
2.1

CVSS Vector:
AV:L/AC:L/Au:N/C:P/I:N/A:N

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-13844
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 86218 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.