English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 148472 CVE descriptions
and 72306 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.851967
Category:SuSE Local Security Checks
Title:SuSE Update for unzip openSUSE-SU-2018:1914-1 (unzip)
Summary:The remote host is missing an update for the 'unzip'; package(s) announced via the openSUSE-SU-2018:1914_1 advisory.
Description:Summary:
The remote host is missing an update for the 'unzip'
package(s) announced via the openSUSE-SU-2018:1914_1 advisory.

Vulnerability Insight:
This update for unzip fixes the following issues:

- CVE-2014-9636: Prevent denial of service (out-of-bounds read or write
and crash) via an extra field with an uncompressed size smaller than the
compressed field size in a zip archive that advertises STORED method
compression (bsc#914442)

- CVE-2018-1000035: Prevent heap-based buffer overflow in the processing
of password-protected archives that allowed an attacker to perform a
denial of service or to possibly achieve code execution (bsc#1080074)

This non-security issue was fixed:

+- Allow processing of Windows zip64 archives (Windows archivers set
total_disks field to 0 but per standard, valid values are 1 and higher)
(bnc#910683)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-709=1

Affected Software/OS:
unzip on openSUSE Leap 15.0.

Solution:
Please install the updated package(s).

CVSS Score:
6.8

CVSS Vector:
AV:N/AC:M/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2014-9636
BugTraq ID: 71825
http://www.securityfocus.com/bid/71825
Debian Security Information: DSA-3152 (Google Search)
http://www.debian.org/security/2015/dsa-3152
http://lists.fedoraproject.org/pipermail/package-announce/2015-January/148792.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-January/148849.html
https://security.gentoo.org/glsa/201611-01
http://seclists.org/oss-sec/2014/q4/489
http://seclists.org/oss-sec/2014/q4/496
http://seclists.org/oss-sec/2015/q1/216
http://seclists.org/oss-sec/2014/q4/1131
http://secunia.com/advisories/62738
http://secunia.com/advisories/62751
http://www.ubuntu.com/usn/USN-2489-1
CopyrightCopyright (C) 2018 Greenbone Networks GmbH

This is only one of 72306 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe

© 1998-2019 E-Soft Inc. All rights reserved.