Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.814818
Category:Mac OS X Local Security Checks
Title:Apple MacOSX Security Updates(HT209446)-03
Summary:Apple Mac OS X is prone to multiple vulnerabilities.
Description:Summary:
Apple Mac OS X is prone to multiple vulnerabilities.

Vulnerability Insight:
Multiple flaws exist due to:

- Multiple memory corruption issues which were addressed with improved input
validation and lock state checking.

- A memory initialization issue which was addressed with improved memory handling.

- A buffer overflow issue which was addressed with improved bounds checking.

- A type confusion issue which was addressed with improved memory handling.

- Multiple out-of-bounds read issues which were addressed with improved input
validation and bounds checking.

Vulnerability Impact:
Successful exploitation will allow remote
attackers to execute arbitrary code with kernel privileges, cause unexpected
changes in memory shared between processes, elevate privileges and read
restricted memory. A malicious application may be able to break out of its
sandbox.

Affected Software/OS:
Apple Mac OS X versions
10.12.x through 10.12.6 build 16G1710, 10.13.x through 10.13.6 build 17G4015,
10.14.x through 10.14.2

Solution:
Upgrade to Apple Mac OS X 10.14.3 or later,
or Apply appropriate patch for 10.12.x or 10.13.x versions. Please see the references for more information.

CVSS Score:
9.3

CVSS Vector:
AV:N/AC:M/Au:N/C:C/I:C/A:C

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2019-6218
BugTraq ID: 106695
http://www.securityfocus.com/bid/106695
https://www.exploit-db.com/exploits/46297/
Common Vulnerability Exposure (CVE) ID: CVE-2019-6208
https://www.exploit-db.com/exploits/46296/
Common Vulnerability Exposure (CVE) ID: CVE-2019-6210
BugTraq ID: 106739
http://www.securityfocus.com/bid/106739
Common Vulnerability Exposure (CVE) ID: CVE-2019-6205
https://www.exploit-db.com/exploits/46299/
http://packetstormsecurity.com/files/156051/XNU-vm_map_copy-Insufficient-Fix.html
Common Vulnerability Exposure (CVE) ID: CVE-2019-6213
https://www.exploit-db.com/exploits/46300/
Common Vulnerability Exposure (CVE) ID: CVE-2019-6214
https://www.exploit-db.com/exploits/46298/
Common Vulnerability Exposure (CVE) ID: CVE-2019-6220
BugTraq ID: 106693
http://www.securityfocus.com/bid/106693
Common Vulnerability Exposure (CVE) ID: CVE-2019-6230
Common Vulnerability Exposure (CVE) ID: CVE-2019-6231
Common Vulnerability Exposure (CVE) ID: CVE-2019-6225
https://www.exploit-db.com/exploits/46248/
CopyrightCopyright (C) 2019 Greenbone Networks GmbH

This is only one of 99761 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.