Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.802259
Category:Mac OS X Local Security Checks
Title:Apple Mac OS X 'i386_set_ldt()' Privilege Escalation Vulnerability
Summary:This host is installed with Mac OS X and is prone to a privilege; escalation vulnerability.
Description:Summary:
This host is installed with Mac OS X and is prone to a privilege
escalation vulnerability.

Vulnerability Insight:
The flaw is due to a privilege checking issue exists in the
i386_set_ldt system call, while handling call gates. This allows local users to gain privileges via vectors
involving the creation of a call gate entry.

Vulnerability Impact:
Successful exploitation will allow attackers to execute arbitrary code
with elevated privileges.

Affected Software/OS:
Mac OS X version 10.6 through 10.6.6

Mac OS X Server version 10.6 through 10.6.6.

Solution:
Upgrade to Mac OS X / Mac OS X Server version 10.6.7 or later.

CVSS Score:
7.2

CVSS Vector:
AV:L/AC:L/Au:N/C:C/I:C/A:C

Cross-Ref: BugTraq ID: 46997
Common Vulnerability Exposure (CVE) ID: CVE-2011-0182
http://lists.apple.com/archives/security-announce/2011/Mar/msg00006.html
http://securityreason.com/securityalert/8402
CopyrightCopyright (C) 2011 Greenbone Networks GmbH

This is only one of 99761 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.