Vulnerability   
Search   
    Search 187964 CVE descriptions
and 85075 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.704685
Category:Debian Local Security Checks
Title:Debian: Security Advisory for apt (DSA-4685-1)
Summary:The remote host is missing an update for the 'apt'; package(s) announced via the DSA-4685-1 advisory.
Description:Summary:
The remote host is missing an update for the 'apt'
package(s) announced via the DSA-4685-1 advisory.

Vulnerability Insight:
Shuaibing Lu discovered that missing input validation in the ar/tar
implementations of APT, the high level package manager, could result in
denial of service when processing specially crafted deb files.

Affected Software/OS:
'apt' package(s) on Debian Linux.

Solution:
For the oldstable distribution (stretch), this problem has been fixed
in version 1.4.10.

For the stable distribution (buster), this problem has been fixed in
version 1.8.2.1.

We recommend that you upgrade your apt packages.

CVSS Score:
4.3

CVSS Vector:
AV:N/AC:M/Au:N/C:N/I:N/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-3810
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/U4PEH357MZM2SUGKETMEHMSGQS652QHH/
https://bugs.launchpad.net/bugs/1878177
https://github.com/Debian/apt/issues/111
https://lists.debian.org/debian-security-announce/2020/msg00089.html
https://salsa.debian.org/apt-team/apt/-/commit/dceb1e49e4b8e4dadaf056be34088b415939cda6
https://tracker.debian.org/news/1144109/accepted-apt-212-source-into-unstable/
https://usn.ubuntu.com/4359-1/
https://usn.ubuntu.com/4359-2/
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 85075 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.