Vulnerability   
Search   
    Search 187964 CVE descriptions
and 85075 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.704679
Category:Debian Local Security Checks
Title:Debian: Security Advisory for keystone (DSA-4679-1)
Summary:The remote host is missing an update for the 'keystone'; package(s) announced via the DSA-4679-1 advisory.
Description:Summary:
The remote host is missing an update for the 'keystone'
package(s) announced via the DSA-4679-1 advisory.

Vulnerability Insight:
A vulnerability was found in the EC2 credentials API of Keystone, the
OpenStack identity service: Any user authenticated within a limited
scope (trust/oauth/application credential) could create an EC2 credential
with an escalated permission, such as obtaining admin while
the user is on a limited viewer
role.

Affected Software/OS:
'keystone' package(s) on Debian Linux.

Solution:
For the stable distribution (buster), this problem has been fixed in
version 2:14.2.0-0+deb10u1.

We recommend that you upgrade your keystone packages.

CVSS Score:
6.5

CVSS Vector:
AV:N/AC:L/Au:S/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2020-12689
Common Vulnerability Exposure (CVE) ID: CVE-2020-12690
Common Vulnerability Exposure (CVE) ID: CVE-2020-12691
Common Vulnerability Exposure (CVE) ID: CVE-2020-12692
CopyrightCopyright (C) 2020 Greenbone Networks GmbH

This is only one of 85075 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.