Vulnerability   
Search   
    Search 191973 CVE descriptions
and 86218 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.702718
Category:Debian Local Security Checks
Title:Debian Security Advisory DSA 2718-1 (wordpress - several vulnerabilities)
Summary:Several vulnerabilities were identified in WordPress, a web blogging;tool. As the CVEs were allocated from releases announcements and;specific fixes are usually not identified, it has been decided to;upgrade the wordpress package to the latest upstream version instead of;backporting the patches.;;This means extra care should be taken when upgrading, especially when;using third-party plugins or themes, since compatibility may have been;impacted along the way. We recommend that users check their install;before doing the upgrade.;;CVE-2013-2173;A denial of service was found in the way WordPress performs hash;computation when checking password for protected posts. An attacker;supplying carefully crafted input as a password could make the;platform use excessive CPU usage.;;CVE-2013-2199Multiple server-side requests forgery (SSRF) vulnerabilities were;found in the HTTP API. This is related to;CVE-2013-0235;,;which was specific to SSRF in pingback requests and was fixed in 3.5.1.;;CVE-2013-2200;Inadequate checking of a user's capabilities could lead to a;privilege escalation, enabling them to publish posts when their;user role should not allow for it and to assign posts to other;authors.;;CVE-2013-2201;Multiple cross-side scripting (XSS) vulnerabilities due to badly;escaped input were found in the media files and plugins upload forms.;;CVE-2013-2202;XML External Entity Injection (XXE) vulnerability via oEmbed;responses.;;CVE-2013-2203;A Full path disclosure (FPD) was found in the file upload mechanism.;If the upload directory is not writable, the error message returned;includes the full directory path.;;CVE-2013-2204;Content spoofing via Flash applet in the embedded tinyMCE media;plugin.;;CVE-2013-2205;Cross-domain XSS in the embedded SWFupload uploader.
Description:Summary:
Several vulnerabilities were identified in WordPress, a web blogging
tool. As the CVEs were allocated from releases announcements and
specific fixes are usually not identified, it has been decided to
upgrade the wordpress package to the latest upstream version instead of
backporting the patches.

This means extra care should be taken when upgrading, especially when
using third-party plugins or themes, since compatibility may have been
impacted along the way. We recommend that users check their install
before doing the upgrade.

CVE-2013-2173
A denial of service was found in the way WordPress performs hash
computation when checking password for protected posts. An attacker
supplying carefully crafted input as a password could make the
platform use excessive CPU usage.

CVE-2013-2199Multiple server-side requests forgery (SSRF) vulnerabilities were
found in the HTTP API. This is related to
CVE-2013-0235
,
which was specific to SSRF in pingback requests and was fixed in 3.5.1.

CVE-2013-2200
Inadequate checking of a user's capabilities could lead to a
privilege escalation, enabling them to publish posts when their
user role should not allow for it and to assign posts to other
authors.

CVE-2013-2201
Multiple cross-side scripting (XSS) vulnerabilities due to badly
escaped input were found in the media files and plugins upload forms.

CVE-2013-2202
XML External Entity Injection (XXE) vulnerability via oEmbed
responses.

CVE-2013-2203
A Full path disclosure (FPD) was found in the file upload mechanism.
If the upload directory is not writable, the error message returned
includes the full directory path.

CVE-2013-2204
Content spoofing via Flash applet in the embedded tinyMCE media
plugin.

CVE-2013-2205
Cross-domain XSS in the embedded SWFupload uploader.

Affected Software/OS:
wordpress on Debian Linux

Solution:
For the oldstable distribution (squeeze), these problems have been fixed in
version 3.5.2+dfsg-1~
deb6u1.

For the stable distribution (wheezy), these problems have been fixed in
version 3.5.2+dfsg-1~
deb7u1.

For the testing distribution (jessie), these problems have been fixed in
version 3.5.2+dfsg-1.

For the unstable distribution (sid), these problems have been fixed in
version 3.5.2+dfsg-1.

We recommend that you upgrade your wordpress packages.

CVSS Score:
6.4

CVSS Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:N

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2013-2201
Debian Security Information: DSA-2718 (Google Search)
http://www.debian.org/security/2013/dsa-2718
Common Vulnerability Exposure (CVE) ID: CVE-2013-2205
BugTraq ID: 60759
http://www.securityfocus.com/bid/60759
Common Vulnerability Exposure (CVE) ID: CVE-2013-2173
Bugtraq: 20130613 Re: WordPress 3.5.1, Denial of Service (Google Search)
http://archives.neohapsis.com/archives/bugtraq/2013-06/0052.html
https://github.com/wpscanteam/wpscan/issues/219
https://vndh.net/note:wordpress-351-denial-service
http://openwall.com/lists/oss-security/2013/06/12/2
Common Vulnerability Exposure (CVE) ID: CVE-2013-2204
Common Vulnerability Exposure (CVE) ID: CVE-2013-2202
Common Vulnerability Exposure (CVE) ID: CVE-2013-2203
Common Vulnerability Exposure (CVE) ID: CVE-2013-0235
http://www.acunetix.com/blog/web-security-zone/wordpress-pingback-vulnerability/
Common Vulnerability Exposure (CVE) ID: CVE-2013-2199
Common Vulnerability Exposure (CVE) ID: CVE-2013-2200
CopyrightCopyright (C) 2013 Greenbone Networks GmbH http://greenbone.net

This is only one of 86218 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.