Vulnerability   
Search   
    Search 191973 CVE descriptions
and 86218 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.702651
Category:Debian Local Security Checks
Title:Debian Security Advisory DSA 2651-1 (smokeping - cross-site scripting vulnerability)
Summary:A cross-site scripting vulnerability was discovered in smokeping, a;latency logging and graphing system. Input passed to the displaymode;;parameter was not properly sanitized. An attacker could use this flaw to;execute arbitrary HTML and script code in a user's browser session in;the context of an affected site.
Description:Summary:
A cross-site scripting vulnerability was discovered in smokeping, a
latency logging and graphing system. Input passed to the displaymode

parameter was not properly sanitized. An attacker could use this flaw to
execute arbitrary HTML and script code in a user's browser session in
the context of an affected site.

Affected Software/OS:
smokeping on Debian Linux

Solution:
For the stable distribution (squeeze), this problem has been fixed in
version 2.3.6-5+squeeze1.

For the testing distribution (wheezy), this problem has been fixed in
version 2.6.7-1.

For the unstable distribution (sid), this problem has been fixed in
version 2.6.7-1.

We recommend that you upgrade your smokeping packages.

CVSS Score:
4.3

CVSS Vector:
AV:N/AC:M/Au:N/C:N/I:P/A:N

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2012-0790
BugTraq ID: 51584
http://www.securityfocus.com/bid/51584
http://holisticinfosec.org/content/view/188/45/
http://www.openwall.com/lists/oss-security/2012/01/21/1
http://secunia.com/advisories/47678
CopyrightCopyright (C) 2013 Greenbone Networks GmbH http://greenbone.net

This is only one of 86218 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.