Vulnerability   
Search   
    Search 191973 CVE descriptions
and 86218 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.702616
Category:Debian Local Security Checks
Title:Debian Security Advisory DSA 2616-1 (nagios3 - buffer overflow in CGI scripts)
Summary:A buffer overflow problem has been found in nagios3, a host/service/network;monitoring and management system. A malicious client could craft a;request to history.cgi and cause application crashes.
Description:Summary:
A buffer overflow problem has been found in nagios3, a host/service/network
monitoring and management system. A malicious client could craft a
request to history.cgi and cause application crashes.

Affected Software/OS:
nagios3 on Debian Linux

Solution:
For the stable distribution (squeeze), this problem has been fixed in
version 3.2.1-2+squeeze1.

For the testing distribution (wheezy), this problem will be fixed soon.

For the unstable distribution (sid), this problem has been fixed in
version 3.4.1-3.

We recommend that you upgrade your nagios3 packages.

CVSS Score:
7.5

CVSS Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2012-6096
BugTraq ID: 56879
http://www.securityfocus.com/bid/56879
Debian Security Information: DSA-2616 (Google Search)
http://www.debian.org/security/2013/dsa-2616
Debian Security Information: DSA-2653 (Google Search)
http://www.debian.org/security/2013/dsa-2653
http://www.exploit-db.com/exploits/24084
http://www.exploit-db.com/exploits/24159
http://lists.grok.org.uk/pipermail/full-disclosure/2012-December/089125.html
http://www.osvdb.org/89170
http://secunia.com/advisories/51863
SuSE Security Announcement: openSUSE-SU-2013:0140 (Google Search)
http://lists.opensuse.org/opensuse-updates/2013-01/msg00033.html
SuSE Security Announcement: openSUSE-SU-2013:0169 (Google Search)
http://lists.opensuse.org/opensuse-updates/2013-01/msg00060.html
SuSE Security Announcement: openSUSE-SU-2013:0188 (Google Search)
http://lists.opensuse.org/opensuse-updates/2013-01/msg00077.html
SuSE Security Announcement: openSUSE-SU-2013:0206 (Google Search)
http://lists.opensuse.org/opensuse-updates/2013-01/msg00088.html
CopyrightCopyright (C) 2013 Greenbone Networks GmbH http://greenbone.net

This is only one of 86218 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2020 E-Soft Inc. All rights reserved.